summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-01 17:21:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-05 00:12:49 +0200
commit7c866c39200b3841b01991385e909e78430a5aa0 (patch)
tree104ba98496401b08619860357991050eee78f246 /gnu
parent7533124d690b579a8adb2e7740af237c42e15549 (diff)
downloadguix-patches-7c866c39200b3841b01991385e909e78430a5aa0.tar
guix-patches-7c866c39200b3841b01991385e909e78430a5aa0.tar.gz
gnu: Add rust-unicode-ident-1.
* gnu/packages/crates-io.scm (rust-unicode-ident-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ad025b785b..143ec5690c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69370,6 +69370,34 @@ char type that allow for the querying if whether or not a character is
a member of a certain category of Unicode characters.")
(license (list license:expat license:asl2.0))))
+(define-public rust-unicode-ident-1
+ (package
+ (name "rust-unicode-ident")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "unicode-ident" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bqswc96ws8l6k7xx56dg521a3l5imi3mhlcz7rsi6a92mxb7xf4"))))
+ (build-system cargo-build-system)
+ ;; Most development inputs are competing implementations
+ ;; for benchmarks.
+ (arguments
+ `(#:skip-build? #t))
+ (home-page "https://github.com/dtolnay/unicode-ident")
+ (synopsis "Implementation of Unicode Standard Annex #31")
+ (description
+ "This package lets you determine whether characters have the
+@code{XID_Start} or @code{XID_Continue} properties according to Unicode
+Standard Annex #31.")
+ ;; For data derived from Unicode Character Database the unicode license
+ ;; applies; for everything else the user may choose between Expat and
+ ;; ASL2.0.
+ (license (list license:expat license:asl2.0
+ license:unicode))))
+
(define-public rust-unicode-linebreak-0.1
(package
(name "rust-unicode-linebreak")