summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Sturmfels <ben@sturm.com.au>2021-08-04 22:29:34 +1000
committerEfraim Flashner <efraim@flashner.co.il>2021-08-05 11:19:38 +0300
commit79fa1fbe23b7a78485b5483bd28e8771d6ed59ce (patch)
treeb00ef65921b9db9cb37cfa3996dfe0e7d8738dfa /gnu
parent28b6f9cadd8c8bda0301f963c6c360465443067d (diff)
downloadguix-patches-79fa1fbe23b7a78485b5483bd28e8771d6ed59ce.tar
guix-patches-79fa1fbe23b7a78485b5483bd28e8771d6ed59ce.tar.gz
gnu: Remove python-fudge.
Remove unused dependency of previously removed fabric package. * gnu/packages/python-xyz.scm (python-fudge): Remove variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 396ce3183d..ddcc96dbe2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17492,39 +17492,6 @@ applications in seconds while maintaining all the flexibility.")
older Pythons because it was not part of the standard library back then.")
(license license:psfl)))
-(define-public python-fudge
- (package
- (name "python-fudge")
- ;; 0.9.6 is the latest version suitable for testing the "fabric" Python 2
- ;; package, which is currently the only use of this package.
- (version "0.9.6")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "fudge" version))
- (sha256
- (base32
- "185ia3vr3qk4f2s1a9hdxb8ci4qc0x0xidrad96pywg8j930qs9l"))))
- (build-system python-build-system)
- (arguments
- `(#:tests? #f)) ;XXX: Tests require the NoseJS Python package.
- (home-page "https://github.com/fudge-py/fudge")
- (synopsis "Replace real objects with fakes/mocks/stubs while testing")
- (description
- "Fudge is a Python module for using fake objects (mocks and stubs) to
-test real ones.
-
-In readable Python code, you declare the methods available on your fake object
-and how they should be called. Then you inject that into your application and
-start testing. This declarative approach means you don’t have to record and
-playback actions and you don’t have to inspect your fakes after running code.
-If the fake object was used incorrectly then you’ll see an informative
-exception message with a traceback that points to the culprit.")
- (license license:expat)))
-
-(define-public python2-fudge
- (package-with-python2 python-fudge))
-
(define-public python-mwclient
(package
(name "python-mwclient")