summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-10-20 22:34:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-11-08 14:06:00 +0100
commit7699f5e4fe2ecad60e1913036d41b12df636cecd (patch)
treea32e8b96003332f93f9cd0760123a2280f6b3808 /gnu
parent94984f490c9665ab893d0df71413928e94b609f6 (diff)
downloadguix-patches-7699f5e4fe2ecad60e1913036d41b12df636cecd.tar
guix-patches-7699f5e4fe2ecad60e1913036d41b12df636cecd.tar.gz
gnu: yoshimi: Fix references to /usr/share.
* gnu/packages/music.scm (yoshimi)[arguments]: Add 'fix-paths' phase. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 567477b6a7..1f62c49449 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3054,6 +3054,13 @@ capabilities, custom envelopes, effects, etc.")
;; Move SSE compiler optimization flags from generic target to
;; athlon64 and core2 targets, because otherwise the build would fail
;; on non-Intel machines.
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (list "src/Interface/InterChange.cpp"
+ "src/Misc/Bank.cpp"
+ "src/Misc/Config.cpp")
+ (("/usr/share") (string-append (assoc-ref outputs "out")
+ "/share")))))
(add-after 'unpack 'remove-sse-flags-from-generic-target
(lambda _
(substitute* "src/CMakeLists.txt"