summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-13 15:00:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 14:44:00 +0100
commit72663b48221668f30b7bdcc502c299757a647156 (patch)
tree074d681bd18915fcf846f77fa3ebc9bba4505fc2 /gnu
parenteccaa8bf8deafbce7bf65b9d3b2822add00219c0 (diff)
downloadguix-patches-72663b48221668f30b7bdcc502c299757a647156.tar
guix-patches-72663b48221668f30b7bdcc502c299757a647156.tar.gz
gnu: WebKitGTK: Update to 2.24.0.
* gnu/packages/webkit.scm (webkitgtk-2.22): Rename to ... (webkitgtk-2.24): ... this. Update to 2.24.0. [inputs]: Add OPENJPEG. * gnu/packages/gnome.scm (eolie, epiphany)[inputs]: Adjust accordingly. * gnu/packages/web-browsers.scm (next-gtk-webkit)[inputs]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/web-browsers.scm2
-rw-r--r--gnu/packages/webkit.scm9
3 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2697beebca..ea6d255c88 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4235,7 +4235,7 @@ work and the interface is well tested.")
("libsecret" ,libsecret)
("gtkspell3" ,gtkspell3)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("webkitgtk" ,webkitgtk-2.22)))
+ ("webkitgtk" ,webkitgtk-2.24)))
(home-page "https://wiki.gnome.org/Apps/Eolie")
(synopsis "Web browser for GNOME")
(description
@@ -4294,7 +4294,7 @@ a secret password store, an adblocker, and a modern UI.")
("libxslt" ,libxslt)
("nettle" ,nettle) ; for hogweed
("sqlite" ,sqlite)
- ("webkitgtk" ,webkitgtk-2.22)))
+ ("webkitgtk" ,webkitgtk-2.24)))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index a19a0dc7c3..b6af572778 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -397,7 +397,7 @@ driven and does not detract you from your daily work.")
(inputs
`(("glib-networking" ,glib-networking)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("webkitgtk" ,webkitgtk-2.22)))
+ ("webkitgtk" ,webkitgtk-2.24)))
(native-inputs
`(("gcc-7" ,gcc-7) ; needed because webkitgtk-2.22 is compiled with gcc-7
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 7a4818609e..14c374dd3e 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -165,20 +165,23 @@ HTML/CSS applications to full-fledged web browsers.")
;; newer version of GCC than our default compiler, and this causes problems
;; when linked with C++ libraries built using our default compiler. For now,
;; we use this newer webkitgtk only for selected packages, e.g. epiphany.
-(define-public webkitgtk-2.22
+(define-public webkitgtk-2.24
(package/inherit webkitgtk
(name "webkitgtk")
- (version "2.22.7")
+ (version "2.24.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1zrhmz90sn30zgyflj4i86fsscws10xsi2kfs87nj2nd0pbggrjb"))))
+ "01s446lmjk7y8il4snjm32vpxws2rp4hmxrwm2swx0p47x8d2jif"))))
(native-inputs
`(("gcc" ,gcc-7) ; webkitgtk-2.22 requires gcc-6 or newer
,@(package-native-inputs webkitgtk)))
+ (inputs
+ `(("openjpeg" ,openjpeg)
+ ,@(package-inputs webkitgtk)))
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:phases phases)