summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-19 06:06:40 -0500
committerArun Isaac <arunisaac@systemreboot.net>2021-11-24 23:59:37 +0530
commit6de284e832fe6056aec7e89823c0be0a46682c39 (patch)
tree97a63aac22d1350ce9ba41c9a4a2fc9a9b62ecb3 /gnu
parent3aac086c3f750b8d3aa793dbd9c72ec3212ab025 (diff)
downloadguix-patches-6de284e832fe6056aec7e89823c0be0a46682c39.tar
guix-patches-6de284e832fe6056aec7e89823c0be0a46682c39.tar.gz
gnu: racket: Update to 8.3.
* gnu/packages/racket.scm (racket-minimal, racket): Update to 8.3. * gnu/packages/racket.scm (racket-minimal)[source]: Remove racket-minimal-backport-1629887.patch from patches. * gnu/packages/patches/racket-minimal-backport-1629887.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/racket-minimal-backport-1629887.patch28
-rw-r--r--gnu/packages/racket.scm11
3 files changed, 5 insertions, 35 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3227fc3835..b9fff951b2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1717,7 +1717,6 @@ dist_patch_DATA = \
%D%/packages/patches/ripperx-missing-file.patch \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
%D%/packages/patches/rtags-separate-rct.patch \
- %D%/packages/patches/racket-minimal-backport-1629887.patch \
%D%/packages/patches/racket-minimal-sh-via-rktio.patch \
%D%/packages/patches/remake-impure-dirs.patch \
%D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch \
diff --git a/gnu/packages/patches/racket-minimal-backport-1629887.patch b/gnu/packages/patches/racket-minimal-backport-1629887.patch
deleted file mode 100644
index aa060ef5aa..0000000000
--- a/gnu/packages/patches/racket-minimal-backport-1629887.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From fb1a6ab205fd63a46669a463931af473e2ac0c87 Mon Sep 17 00:00:00 2001
-From: Matthew Flatt <mflatt@racket-lang.org>
-Date: Sat, 21 Aug 2021 15:29:59 -0600
-Subject: [PATCH] setup/variant: recognize starter executables
-
-Related to #3969
-
-(cherry picked from commit 1629887071fe3cc8fe8af0a7aa0d3912509cb058)
----
- racket/collects/setup/variant.rkt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/racket/collects/setup/variant.rkt b/racket/collects/setup/variant.rkt
-index 81da6f5701..b23131e481 100644
---- a/racket/collects/setup/variant.rkt
-+++ b/racket/collects/setup/variant.rkt
-@@ -25,7 +25,7 @@
- (and (file-exists? f)
- (with-input-from-file f
- (lambda ()
-- (define m (regexp-match #rx#"bINARy tYPe:..(.)"
-+ (define m (regexp-match #rx#"bINARy tYPe:e?..(.)"
- (current-input-port)))
- (cond
- [(not m) '3m]
---
-2.30.2
-
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 661443e0c3..5b142acdec 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -128,7 +129,7 @@
(define-public racket-minimal
(package
(name "racket-minimal")
- (version "8.2") ; note: remember to also update racket!
+ (version "8.3") ; note: remember to also update racket!
(source
(origin
(method git-fetch)
@@ -136,11 +137,9 @@
(url "https://github.com/racket/racket")
(commit (string-append "v" version))))
(sha256
- "061bhiyjlvazph0dj9i3i3x2q5z53rp8h5cjwg3frjimkr45lncn")
+ "1i1jnv1wb0kanfg47hniafx2vhwjc33qqx66lq7wkf5hbmgsyws3")
(file-name (git-file-name name version))
- (patches (search-patches "racket-minimal-sh-via-rktio.patch"
- ;; Remove the following in version 8.3:
- "racket-minimal-backport-1629887.patch"))
+ (patches (search-patches "racket-minimal-sh-via-rktio.patch"))
(modules '((guix build utils)))
(snippet
(with-imported-modules '((guix build utils))
@@ -427,7 +426,7 @@ Chez Scheme.")
%installer-mirrors))
(sha256
(base32
- "10sgzsraxzxp1k2y2wvz8rcjwvhbcd6k72l9lyqr34yazlwfdz26"))
+ "0jdr0y7scvv2a3sq456ifrgq0yfsbiwavdf2m86zmrapp481mby4"))
(snippet
#~(begin
(use-modules (guix build utils)