summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-07-26 15:01:36 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-26 15:21:14 +0300
commit6bd6b12350e18611ade8bc79b80f633afcef86ec (patch)
tree7fa95ad7a17e3d868e89384ab1f9655bdc499311 /gnu
parentab751d5320b74e088f9e71d2ad3fd31fd73ae1bf (diff)
downloadguix-patches-6bd6b12350e18611ade8bc79b80f633afcef86ec.tar
guix-patches-6bd6b12350e18611ade8bc79b80f633afcef86ec.tar.gz
gnu: Add xmenu.
* gnu/packages/wm.scm (xmenu): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wm.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e6cb197e92..081e059326 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1924,3 +1924,40 @@ wasting your precious memory.")
(description "@code{xclickroot} runs a command every time a given mouse
button is pressed on the root window.")
(license license:public-domain))))
+
+(define-public xmenu
+ (package
+ (name "xmenu")
+ (version "3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phillbush/xmenu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sw9l87fh03jp03a2v7rhgpyx29yg2x9blzfzp40jwad2whs7m7n"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxft" ,libxft)
+ ("freetype" ,freetype)
+ ("imlib2" ,imlib2)))
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "CFLAGS="
+ "-I" (assoc-ref %build-inputs "freetype")
+ "/include/freetype2"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/phillbush/xmenu")
+ (synopsis "Menu utility for X")
+ (description "@code{xmenu} receives a menu specification in stdin, shows
+a menu for the user to select one of the options, and outputs the option
+selected to stdout. It can be controlled both via mouse and via keyboard.")
+ (license license:public-domain)))