summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-09 15:49:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:36 +0100
commit6b4c911a99c677d67d826e8d5e53394bf1d3282e (patch)
tree604f3b890905275150e0cde8502eb135b912713d /gnu
parente833d3abf8445b604b5585a1182d07cfd7de1f19 (diff)
downloadguix-patches-6b4c911a99c677d67d826e8d5e53394bf1d3282e.tar
guix-patches-6b4c911a99c677d67d826e8d5e53394bf1d3282e.tar.gz
gnu: scvelo: Make compatible with latest matplotlib.
* gnu/packages/bioinformatics.scm (scvelo)[arguments]: Add phase 'matplotlib-compatibility. Change-Id: Ia761821c8aa1e516525cff7c680db471a5908e5f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 153b190630..70ba4d65a5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -20799,6 +20799,11 @@ aligner.")
'(list "-k" "not test_perfect_fit and not test_perfect_fit_2d")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'matplotlib-compatibility
+ (lambda _
+ (substitute* "scvelo/settings.py"
+ (("warnings.filterwarnings\\(\"ignore\", category=cbook.mplDeprecation\\)")
+ ""))))
;; Numba needs a writable dir to cache functions.
(add-before 'check 'set-numba-cache-dir
(lambda _