summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-14 12:42:23 +0200
committerMarius Bakke <marius@gnu.org>2021-05-15 19:18:46 +0200
commit6b496f7b32db9602b23da6fff5d3328b6ab0c485 (patch)
tree81f17685e947e3f9b23589fc2dbccad4058b55fc /gnu
parentd4f02447ff4ee94e78ce59381460b7979186397a (diff)
downloadguix-patches-6b496f7b32db9602b23da6fff5d3328b6ab0c485.tar
guix-patches-6b496f7b32db9602b23da6fff5d3328b6ab0c485.tar.gz
gnu: arpack-ng: Update to 3.8.0.
* gnu/packages/maths.scm (arpack-ng): Update to 3.8.0. [native-inputs]: Add PKG-CONFIG. [inputs]: Add EIGEN.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 9f7bdb9bb1..52d7c6f75a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -770,7 +770,7 @@ halfspaces) or by their double description with both representations.")
(define-public arpack-ng
(package
(name "arpack-ng")
- (version "3.6.3")
+ (version "3.8.0")
(home-page "https://github.com/opencollab/arpack-ng")
(source (origin
(method git-fetch)
@@ -778,14 +778,16 @@ halfspaces) or by their double description with both representations.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wljl96yqxc9v8r49c37lscwkdp58kaacfb9p6s6nvpm31haax4y"))))
+ "0l7as5z6xvbxly8alam9s4kws70952qq35a6vkljzayi4b9gbklx"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("libtool" ,libtool)))
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("lapack" ,lapack)
+ `(("eigen" ,eigen)
+ ("lapack" ,lapack)
("fortran" ,gfortran)))
(synopsis "Fortran subroutines for solving eigenvalue problems")
(description