summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-09-19 21:51:44 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-09-19 23:02:51 +0200
commit6b1253718d1d660e7a91bd59a96bdb16d7c5e0b3 (patch)
tree1d346e0542ee49aa69fd2385e340e430d1b1563b /gnu
parent1bc5a77f0a346c3c4156d8443de4d709a652e6e1 (diff)
downloadguix-patches-6b1253718d1d660e7a91bd59a96bdb16d7c5e0b3.tar
guix-patches-6b1253718d1d660e7a91bd59a96bdb16d7c5e0b3.tar.gz
gnu: u-boot: Reomve sdl2 dependency on non-GUI builds.
* gnu/packages/bootloaders.scm (u-boot)[native-inputs]: Remove sdl2. (u-boot-tools)[native-inputs]: Add sdl2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 769238203c..d1de5cea4e 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -465,7 +465,6 @@ tree binary files. These are board description files used by Linux and BSD.")
("python" ,python)
("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)
- ("sdl2" ,sdl2)
("swig" ,swig)))
(build-system gnu-build-system)
(home-page "https://www.denx.de/wiki/U-Boot/")
@@ -478,6 +477,9 @@ also initializes the boards (RAM etc).")
(package
(inherit u-boot)
(name "u-boot-tools")
+ (native-inputs
+ `(("sdl2" ,sdl2)
+ ,@(package-native-inputs u-boot)))
(arguments
`(#:make-flags '("HOSTCC=gcc")
#:test-target "tests"