summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 15:30:06 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:25 +0300
commit697eb08750531ed0f9ae097de78698a23338ef9e (patch)
treeddb9e8f0a257895b5ee1f8da626a2d7cebcfb66f /gnu
parent398183543453f84b10af3901b0e40f0f57394334 (diff)
downloadguix-patches-697eb08750531ed0f9ae097de78698a23338ef9e.tar
guix-patches-697eb08750531ed0f9ae097de78698a23338ef9e.tar.gz
gnu: Add go-github-com-google-go-github.
* gnu/packages/golang.scm (go-github-com-google-go-github): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb444dcbaf..60ef3bb6bc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3955,6 +3955,33 @@ and from termios translations, readCh, reading passwords, etc.")
into URL query parameters.")
(license license:bsd-3))))
+(define-public go-github-com-google-go-github
+ (package
+ (name "go-github-com-google-go-github")
+ (version "26.1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-github")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x0zz1vcmllp6r6l2qin9b2llm5cxbf6n84rf99h8wrmhvzs2ipi"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ;application/octet-stream instead of text/plain
+ #:import-path "github.com/google/go-github/v26/github"
+ #:unpack-path "github.com/google/go-github/v26"))
+ (native-inputs
+ `(("go-github-com-google-go-querystring" ,go-github-com-google-go-querystring)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+ (home-page "https://github.com/google/go-github/")
+ (synopsis "Client library for accessing the GitHub API v3")
+ (description "@code{go-github} is a Go client library for accessing the
+GitHub API v3.")
+ (license license:bsd-3)))
+
(define-public go-golang.org-x-sync-errgroup
(let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
(revision "0"))