summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-04 12:49:43 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-04 12:49:43 +0200
commit67dfa1986d7e8af9a42ffa7c9d2b40599857cf19 (patch)
tree87364788f14fbf9ade52e18de680d80fcf535c97 /gnu
parent696062b1f06194f6c276ff6889ce2f19b1755eaf (diff)
downloadguix-patches-67dfa1986d7e8af9a42ffa7c9d2b40599857cf19.tar
guix-patches-67dfa1986d7e8af9a42ffa7c9d2b40599857cf19.tar.gz
gnu: findutils: Use /var as the localstatedir, for 'updatedb'.
* gnu/packages/patches/findutils-localstatedir.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (findutils)[source]: Use it. [arguments]: Pass --localstatedir=/var.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm18
-rw-r--r--gnu/packages/patches/findutils-localstatedir.patch14
2 files changed, 26 insertions, 6 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 0a27093966..e59abd035c 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -206,14 +206,20 @@ interactive means to merge two files.")
(sha256
(base32
"0amn0bbwqvsvvsh6drfwz20ydc2czk374lzw5kksbh6bf78k4ks3"))
- (patches (list (search-patch "findutils-absolute-paths.patch")))))
+ (patches (map search-patch
+ '("findutils-absolute-paths.patch"
+ "findutils-localstatedir.patch")))))
(build-system gnu-build-system)
(arguments
- ;; Work around cross-compilation failure.
- ;; See <http://savannah.gnu.org/bugs/?27299#comment1>.
- (if (%current-target-system)
- '(#:configure-flags '("gl_cv_func_wcwidth_works=yes"))
- '()))
+ `(#:configure-flags (list
+ ;; Tell 'updatedb' to write to /var.
+ "--localstatedir=/var"
+
+ ;; Work around cross-compilation failure. See
+ ;; <http://savannah.gnu.org/bugs/?27299#comment1>.
+ ,@(if (%current-target-system)
+ '("gl_cv_func_wcwidth_works=yes")
+ '()))))
(synopsis "Operating on files matching given criteria")
(description
"Findutils supplies the basic file directory searching utilities of the
diff --git a/gnu/packages/patches/findutils-localstatedir.patch b/gnu/packages/patches/findutils-localstatedir.patch
new file mode 100644
index 0000000000..c774303cf1
--- /dev/null
+++ b/gnu/packages/patches/findutils-localstatedir.patch
@@ -0,0 +1,14 @@
+Do not try to create $localstatedir (aka. /var) since we don't have
+write access.
+
+--- findutils-4.4.2/locate/Makefile.in 2015-06-04 12:40:52.690935795 +0200
++++ findutils-4.4.2/locate/Makefile.in 2015-06-04 12:41:32.087286685 +0200
+@@ -1212,7 +1212,7 @@ updatedb: updatedb.sh Makefile
+ chmod +x $@
+
+ install-data-hook:
+- $(top_srcdir)/build-aux/mkinstalldirs $(DESTDIR)$(localstatedir)
++ true
+
+ dblocation.texi: Makefile
+ echo '@set LOCATE_DB $(LOCATE_DB)' > $@