summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-28 16:14:03 -0500
committerLeo Famulari <leo@famulari.name>2015-12-30 21:26:05 -0500
commit658212ebf74a28f5a4b035f9fe2100fbc5d89e47 (patch)
tree94aebbd95ba07eefff4dc83d463df3635a55f1c2 /gnu
parent2ef8bbc3ae2c24ed89e482b7570197d44b35ed7f (diff)
downloadguix-patches-658212ebf74a28f5a4b035f9fe2100fbc5d89e47.tar
guix-patches-658212ebf74a28f5a4b035f9fe2100fbc5d89e47.tar.gz
gnu: Move cursynth to (gnu packages music).
* gnu/packages/cursynth.scm: Remove. * gnu/packages/music.scm (cursynth): New variable, from cursynth.scm. * gnu-system.am (GNU_SYSTEM_MODULES): Remove cursynth.scm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cursynth.scm53
-rw-r--r--gnu/packages/music.scm27
2 files changed, 27 insertions, 53 deletions
diff --git a/gnu/packages/cursynth.scm b/gnu/packages/cursynth.scm
deleted file mode 100644
index 80f86da241..0000000000
--- a/gnu/packages/cursynth.scm
+++ /dev/null
@@ -1,53 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages cursynth)
- #:use-module (guix packages)
- #:use-module (guix licenses)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages linux))
-
-(define-public cursynth
- (package
- (name "cursynth")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/cursynth/cursynth-"
- version ".tar.gz"))
- (sha256
- (base32 "1dhphsya41rv8z6yqcv9l6fwbslsds4zh1y56zizi39nd996d40v"))
- (patches (list (search-patch "cursynth-wave-rand.patch")))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
- ;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
- ;; prevents us from using pulseaudio
- (inputs `(("ncurses" ,ncurses)
- ("alsa" ,alsa-lib)))
- (home-page "http://www.gnu.org/software/cursynth")
- (synopsis "Polyphonic and MIDI subtractive music synthesizer using curses")
- (description "GNU cursynth is a polyphonic synthesizer that runs
-graphically in the terminal. It is built on a full-featured subtractive
-synthesis engine. Notes and parameter changes may be entered via MIDI or the
-computer's keyboard.")
- (license gpl3+)))
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 264fcd9d0f..fd1751e95b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;;
@@ -1004,3 +1005,29 @@ synthesizer. It offers three synthesizer engines, multitimbral and polyphonic
synths, microtonal capabilities, custom envelopes, effects, etc. Yoshimi
improves on support for JACK features, such as JACK MIDI.")
(license license:gpl2)))
+
+(define-public cursynth
+ (package
+ (name "cursynth")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/cursynth/cursynth-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1dhphsya41rv8z6yqcv9l6fwbslsds4zh1y56zizi39nd996d40v"))
+ (patches (list (search-patch "cursynth-wave-rand.patch")))))
+ (build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ ;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
+ ;; prevents us from using pulseaudio
+ (inputs `(("ncurses" ,ncurses)
+ ("alsa" ,alsa-lib)))
+ (home-page "http://www.gnu.org/software/cursynth")
+ (synopsis "Polyphonic and MIDI subtractive music synthesizer using curses")
+ (description "GNU cursynth is a polyphonic synthesizer that runs
+graphically in the terminal. It is built on a full-featured subtractive
+synthesis engine. Notes and parameter changes may be entered via MIDI or the
+computer's keyboard.")
+ (license license:gpl3+)))