summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-04-14 23:54:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-15 11:00:02 +0300
commit64fe44fa84fb734d3ab4a36c7fd42dea9ce71338 (patch)
treec01ada6c9bd1fd43e248d96d1ada98d9e9ce3e62 /gnu
parent1bab9b9f17256a9e4f45f5b0cceb8b52e0a1b1ed (diff)
downloadguix-patches-64fe44fa84fb734d3ab4a36c7fd42dea9ce71338.tar
guix-patches-64fe44fa84fb734d3ab4a36c7fd42dea9ce71338.tar.gz
gnu: Add python-roman.
* gnu/packages/python-xyz.scm (python-roman): New variable. Co-authored-by: jgart <jgart@dismail.de> Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c01993ecd7..bc1f4597f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3029,6 +3029,25 @@ cutting and pasting that code over and over.")
(define-public python2-kitchen
(package-with-python2 python-kitchen))
+(define-public python-roman
+ (package
+ (name "python-roman")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "roman" version))
+ (sha256
+ (base32
+ "0gyp2bmw47jgpm8j64gydzqq838bgxz5gh6cm57lxlr7p26sqiic"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/zopefoundation/roman")
+ (synopsis "Integer to Roman numerals converter")
+ (description
+ "This package provides a small helper library to convert Arabic Numbers
+to Roman Numerals.")
+ (license license:psfl)))
+
(define-public python-unidecode
(package
(name "python-unidecode")