summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-02-03 18:08:35 -0500
committerCarl Dong <contact@carldong.me>2021-02-25 20:51:05 -0500
commit62942992831249d6d1c047c0a11c41d2ecccc4fc (patch)
tree76db72ec044787a1224a82f5dd3c0674e2f63528 /gnu
parent811a2015a28f328e2076bb6a78562c3c2b81dd91 (diff)
downloadguix-patches-62942992831249d6d1c047c0a11c41d2ecccc4fc.tar
guix-patches-62942992831249d6d1c047c0a11c41d2ecccc4fc.tar.gz
gnu: Return appropriate defconfig for ppc64 (non-LE)
* gnu/packages/linux.scm (system->defconfig): Add "powerpc64-" prefix.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 86cf30b471..80afd125d9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -184,6 +184,7 @@
defconfig. Return the appropriate make target if applicable, otherwise return
\"defconfig\"."
(cond ((string-prefix? "powerpc-" system) "pmac32_defconfig")
+ ((string-prefix? "powerpc64-" system) "ppc64_defconfig")
((string-prefix? "powerpc64le-" system) "ppc64_defconfig")
(else "defconfig")))