summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2022-08-22 09:54:35 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-08-24 18:21:05 +0200
commit6256e267da0e134e76364cc28b6b397ecdf4e74f (patch)
tree1c7c9aa87bfeb06fb706d1cb7fa0185098c72e64 /gnu
parent09e3ab6fbfa3749e577cd01362a8bf5a5a53e8a3 (diff)
downloadguix-patches-6256e267da0e134e76364cc28b6b397ecdf4e74f.tar
guix-patches-6256e267da0e134e76364cc28b6b397ecdf4e74f.tar.gz
gnu: Add ocaml-afl-persistent.
* gnu/packages/ocaml.scm (ocaml-afl-persistent): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 79df84054f..bb1d952bb8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8561,6 +8561,40 @@ It makes it possible to run pure OCaml programs in JavaScript environment like
browsers and Node.js.")
(license license:lgpl2.1+)))
+(define-public ocaml-afl-persistent
+ (package
+ (name "ocaml-afl-persistent")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stedolan/ocaml-afl-persistent")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06yyds2vcwlfr2nd3gvyrazlijjcrd1abnvkfpkaadgwdw3qam1i"))))
+ (build-system ocaml-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "./build.sh")))
+ ;; XXX: The tests are already run in the build.sh script.
+ (delete 'check))))
+ (native-inputs
+ `(("opam" ,opam)))
+ (home-page "https://github.com/stedolan/ocaml-afl-persistent")
+ (synopsis "Use afl-fuzz in persistent mode")
+ (description
+ "afl-fuzz normally works by repeatedly forking the program being tested.
+Using this package, you can run afl-fuzz in ``persistent mode'', which avoids
+repeated forking and is much faster.")
+ (license license:expat)))
+
(define-public ocaml-bibtex2html
(package
(name "ocaml-bibtex2html")