summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-24 23:45:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-24 23:59:45 -0400
commit61e3b86cbf2238d13a557722e69cf3b343fa427d (patch)
treef3e89c45aafaaf4c3350686db17e96c627060af1 /gnu
parent6c2506d8df2c9254835637a1ac6a68ada11de781 (diff)
downloadguix-patches-61e3b86cbf2238d13a557722e69cf3b343fa427d.tar
guix-patches-61e3b86cbf2238d13a557722e69cf3b343fa427d.tar.gz
gnu: Add python-fancycompleter.
* gnu/packages/python-xyz.scm (python-fancycompleter): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b659513800..f9492908a3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5558,6 +5558,35 @@ controlling Xorg windows using Python. The library relies on the
@command{wmctrl} to do so.")
(license license:expat)))
+(define-public python-fancycompleter
+ (package
+ (name "python-fancycompleter")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fancycompleter" version))
+ (sha256
+ (base32 "0wkj4h01pxa8prv59zl09a0i3w26k835bfpjgvyvsai4mswgxq09"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-setup.py
+ (lambda _
+ (substitute* "setup.py"
+ ((".*setupmeta.*")
+ "")
+ (("versioning=.*")
+ (string-append "version='" ,version "',"))
+ ((".*pyrepl.*") ;broken on Python 3
+ "")))))))
+ (home-page "https://github.com/pdbpp/fancycompleter")
+ (synopsis "TAB completion library for Python")
+ (description "@code{fancycompleter} is a module that adds TAB completion
+to the interactive prompt. It is an extension of the @code{rlcompleter}
+module from the standard Python library.")
+ (license license:bsd-3)))
+
(define-public python-pdftotext
(package
(name "python-pdftotext")