summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-07-02 23:24:51 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-04 00:30:25 +0200
commit619d164c803b5c3cf540cdab99d99ec8c4eedcf5 (patch)
treeb5c6601e372ab9f67e2a60605a25f2cf901da814 /gnu
parent5b8b0c78fd54b3d7f3503a34feb967c6df7ea135 (diff)
downloadguix-patches-619d164c803b5c3cf540cdab99d99ec8c4eedcf5.tar
guix-patches-619d164c803b5c3cf540cdab99d99ec8c4eedcf5.tar.gz
gnu: Add emacs-org-beautify-theme.
* gnu/packages/emacs-xyz.scm (emacs-org-beautify-theme): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c732c63cc5..8b38673f3f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -76,6 +76,7 @@
;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3549,6 +3550,31 @@ naming style of a symbol. It supports different naming conventions such as:
tables.")
(license license:gpl2+)))
+(define-public emacs-org-beautify-theme
+ ;; Latest release (0.4) is not tagged, use commit hash.
+ (let ((commit "df6a1114fda313e1689363e196c8284fbe2a2738")
+ (revision "0"))
+ (package
+ (name "emacs-org-beautify-theme")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonnay/org-beautify-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lkz7736swimad12khwbbqc4gxjydgr1k45p4mx03s25pv1w920y"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jonnay/org-beautify-theme")
+ (synopsis "Theme to make Org mode look more beautiful")
+ (description
+ "The theme adds padding between headings, increases the size of titles,
+strike through completed TODO headings, changes Org blocks, changes Org check
+boxes, and more.")
+ (license license:gpl3+))))
+
(define-public emacs-org-rich-yank
(package
(name "emacs-org-rich-yank")