summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-29 23:56:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:00 +0100
commit5f1000d5d4cc4dfc9a1fe220457c17ad011d9e33 (patch)
tree6b2e328bd002b20c9d90191d0fde2aa484a29fb4 /gnu
parent8aeac338a7084720a0143f54b83e39d18a2edcdc (diff)
downloadguix-patches-5f1000d5d4cc4dfc9a1fe220457c17ad011d9e33.tar
guix-patches-5f1000d5d4cc4dfc9a1fe220457c17ad011d9e33.tar.gz
gnu: libffi: Update to 3.3.
* gnu/packages/patches/libffi-3.2.1-complex-alpha.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libffi.scm (libffi): Update to 3.3. [source](patches): Remove. * gnu/packages/python.scm (python-3.7)[arguments]: Remove workaround.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/libffi.scm15
-rw-r--r--gnu/packages/patches/libffi-3.2.1-complex-alpha.patch28
-rw-r--r--gnu/packages/python.scm7
4 files changed, 4 insertions, 47 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 25dfef3849..f13d8f3645 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1066,7 +1066,6 @@ dist_patch_DATA = \
%D%/packages/patches/libgnome-encoding.patch \
%D%/packages/patches/libgnomeui-utf8.patch \
%D%/packages/patches/libgpg-error-gawk-compat.patch \
- %D%/packages/patches/libffi-3.2.1-complex-alpha.patch \
%D%/packages/patches/libjpeg-turbo-CVE-2019-2201.patch \
%D%/packages/patches/libjxr-fix-function-signature.patch \
%D%/packages/patches/libjxr-fix-typos.patch \
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index b61dbc8657..52654ddf3f 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -41,7 +41,7 @@
(define-public libffi
(package
(name "libffi")
- (version "3.2.1")
+ (version "3.3")
(source (origin
(method url-fetch)
(uri
@@ -49,21 +49,12 @@
name "-" version ".tar.gz"))
(sha256
(base32
- "0dya49bnhianl0r65m65xndz6ls2jn1xngyn72gd28ls3n7bnvnh"))
- (patches (search-patches "libffi-3.2.1-complex-alpha.patch"))))
+ "0mi0cpf8aa40ljjmzxb7im6dbj45bb0kllcd09xgmp834y9agyvj"))))
(build-system gnu-build-system)
(arguments
`(;; Prevent the build system from passing -march and -mtune to the
;; compiler. See "ax_cc_maxopt.m4" and "ax_gcc_archflag.m4".
- #:configure-flags '("--enable-portable-binary" "--without-gcc-arch")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (define out (assoc-ref outputs "out"))
- (symlink (string-append out "/lib/libffi-3.2.1/include")
- (string-append out "/include"))
- #t)))))
+ #:configure-flags '("--enable-portable-binary" "--without-gcc-arch")))
(outputs '("out" "debug"))
(synopsis "Foreign function call interface library")
(description
diff --git a/gnu/packages/patches/libffi-3.2.1-complex-alpha.patch b/gnu/packages/patches/libffi-3.2.1-complex-alpha.patch
deleted file mode 100644
index ebbc0635a5..0000000000
--- a/gnu/packages/patches/libffi-3.2.1-complex-alpha.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-The patch fixes build failure of form:
- ../src/alpha/osf.S:298:2: error: #error "osf.S out of sync with ffi.h"
-Upstream fixed the bug in a more invasive way
-but didn't have releases since 3.2.1.
-
-The patch is taken from Gentoo:
-https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-libs/libffi/files/libffi-3.2.1-complex_alpha.patch
-
---- libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:15.000000000 +0100
-+++ libffi-3.2.1/src/alpha/osf.S 2015-01-16 10:46:24.000000000 +0100
-@@ -279,6 +279,7 @@
- .gprel32 $load_64 # FFI_TYPE_SINT64
- .gprel32 $load_none # FFI_TYPE_STRUCT
- .gprel32 $load_64 # FFI_TYPE_POINTER
-+ .gprel32 $load_none # FFI_TYPE_COMPLEX
-
- /* Assert that the table above is in sync with ffi.h. */
-
-@@ -294,7 +295,8 @@
- || FFI_TYPE_SINT64 != 12 \
- || FFI_TYPE_STRUCT != 13 \
- || FFI_TYPE_POINTER != 14 \
-- || FFI_TYPE_LAST != 14
-+ || FFI_TYPE_COMPLEX != 15 \
-+ || FFI_TYPE_LAST != 15
- #error "osf.S out of sync with ffi.h"
- #endif
-
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 43b4044e72..ef1c8e4a09 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -377,12 +377,7 @@ data types.")
" --exclude test_mmap"
;; test_socket may hang and eventually run out of memory
;; on some systems: <https://bugs.python.org/issue34587>.
- " test_socket"
- ;; XXX: test_ctypes fails on some platforms due to a problem in
- ;; libffi 3.2.1: <https://bugs.python.org/issue23249>.
- ,@(if (string-prefix? "aarch64" (%current-system))
- '(" test_ctypes")
- '()))))
+ " test_socket")))
((#:phases phases)
`(modify-phases ,phases
(add-before 'check 'set-TZDIR