summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-11 21:11:52 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-13 19:14:12 +0200
commit5e33305f3848a574fb671d9d8593aa6bda817a4e (patch)
treec5c1c1c61a27f8ccbfb65eb916f243163238736e /gnu
parent8b3e8eabdb1e672e9dd4ce4fa3ccc2507cabb657 (diff)
downloadguix-patches-5e33305f3848a574fb671d9d8593aa6bda817a4e.tar
guix-patches-5e33305f3848a574fb671d9d8593aa6bda817a4e.tar.gz
gnu: Add rust-rowan-0.13.
* gnu/packages/crates-io.scm (rust-rowan-0.13): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 426e700d43..b08314fcc2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35847,6 +35847,39 @@ can handle huge texts and memory-incoherent edits with ease.")
wildcard segments")
(license license:expat)))
+(define-public rust-rowan-0.13
+ (package
+ (name "rust-rowan")
+ (version "0.13.0-pre.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rowan" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03gh3wa52135mh1an1x4hw6jba64fwfsh4lw3fsmm6jy2i7c1k42"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-countme" ,rust-countme-2)
+ ("rust-hashbrown" ,rust-hashbrown-0.9)
+ ("rust-memoffset" ,rust-memoffset-0.6)
+ ("rust-rustc-hash" ,rust-rustc-hash-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-text-size" ,rust-text-size-1))
+ #:cargo-development-inputs
+ (("rust-m-lexer" ,rust-m-lexer-0.0.4))))
+ (home-page
+ "https://github.com/rust-analyzer/rowan")
+ (synopsis
+ "Library for generic lossless syntax trees")
+ (description
+ "This package provides a library for generic lossless syntax trees.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rspec-1
(package
(name "rust-rspec")