summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-08-10 09:55:17 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-08-10 12:10:26 +0200
commit5d6ff1e8282f31c3590d8dacfb90f175d7b16e72 (patch)
tree2973ce945a62142bfb2c762927ddd169e90412cd /gnu
parent0f89ec799e391d9d2453a929bca7a2a906d3435f (diff)
downloadguix-patches-5d6ff1e8282f31c3590d8dacfb90f175d7b16e72.tar
guix-patches-5d6ff1e8282f31c3590d8dacfb90f175d7b16e72.tar.gz
gnu: Add python-devtools.
* gnu/packages/python-xyz.scm (python-devtools): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4102902465..50c36a1e03 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21569,3 +21569,35 @@ and have a maximum lifetime built-in.")
"This package contains a small collection of test tool plugins for
@code{nose2} and @code{flake8}.")
(license license:asl2.0)))
+
+(define-public python-devtools
+ (package
+ (name "python-devtools")
+ (version "0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/samuelcolvin/python-devtools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15zczdcm90wl54c68f1qjb05nkd5bjsc9xjl3lk4frs7k7wkmrvp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-mock" ,python-pytest-mock)))
+ (propagated-inputs
+ `(("python-pygments" ,python-pygments)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest")
+ #t)))))
+ (home-page "https://github.com/samuelcolvin/python-devtools")
+ (synopsis "Debug command and development tools")
+ (description
+ "This package provides a debug print command and other development tools.
+It adds a simple and readable way to print stuff during development.")
+ (license license:expat)))