summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 08:45:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:18 +0200
commit5ce53a4d1c6e88f3ac072ce86ef4746912399298 (patch)
tree60183959cc8b76db28c3520e3d1f5a8a7b19ab6c /gnu
parent89f1a4a415fb00723522e786edf519deb6dd40e7 (diff)
downloadguix-patches-5ce53a4d1c6e88f3ac072ce86ef4746912399298.tar
guix-patches-5ce53a4d1c6e88f3ac072ce86ef4746912399298.tar.gz
gnu: Remove python2-ipykernel.
* gnu/packages/python-xyz.scm (python2-ipykernel): Remove variable. (python-ipykernel)[properties]: Remove python2-variant.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 828a3561fc..5a311d409c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7303,38 +7303,6 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(synopsis "IPython Kernel for Jupyter")
(description
"This package provides the IPython kernel for Jupyter.")
- (properties `((python2-variant . ,(delay python2-ipykernel))))
- (license license:bsd-3)))
-
-;; Version 5.x and above no longer support Python 2.
-(define-public python2-ipykernel
- (package
- (name "python2-ipykernel")
- (version "4.10.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "ipykernel" version))
- (sha256
- (base32 "1yzmdiy1djsszqp54jzd8ym8h4hpl67zjq83j2kxbkp0rwmlpdzf"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2))
- (propagated-inputs
- `(("python2-ipython" ,python2-ipython)
- ;; imported at runtime during connect
- ("python2-jupyter-client" ,python2-jupyter-client)
- ("python2-tornado" ,python2-tornado)
- ("python2-traitlets" ,python2-traitlets)))
- (native-inputs
- `(("python2-mock" ,python2-mock)
- ("python2-nose" ,python2-nose)
- ("python2-pytest" ,python2-pytest)
- ("python2-pytest-cov" ,python2-pytest-cov)))
- (home-page "https://ipython.org")
- (synopsis "IPython Kernel for Jupyter")
- (description
- "This package provides the IPython kernel for Jupyter.")
(license license:bsd-3)))
(define-public python-pari-jupyter