summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 16:05:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 17:48:05 +0300
commit5b6ac91ee4cd44df599f1e55156aa5e362da6d66 (patch)
tree42bdf9429cd8169c79d9317867e9038a2a806576 /gnu
parente22145ed3586984b13381c590e6c8c8c46b479bf (diff)
downloadguix-patches-5b6ac91ee4cd44df599f1e55156aa5e362da6d66.tar
guix-patches-5b6ac91ee4cd44df599f1e55156aa5e362da6d66.tar.gz
gnu: Remove python-setuptools-scm/next.
* gnu/packages/python-xyz.scm (python-setuptools-scm/next): Remove variable. (python-pikepdf) [native-inputs]: Swap for python-setuptools-scm. * gnu/packages/python-compression.scm (python-multivolumefile, python-bcj-cffi, python-ppmd-cffi, python-p77zr)[native-inputs]: Same. * gnu/packages/pep.scm (python-pep-adapter)[native-inputs]: Same.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pep.scm2
-rw-r--r--gnu/packages/python-compression.scm8
-rw-r--r--gnu/packages/python-xyz.scm14
3 files changed, 6 insertions, 18 deletions
diff --git a/gnu/packages/pep.scm b/gnu/packages/pep.scm
index aa0d786d87..dde316e153 100644
--- a/gnu/packages/pep.scm
+++ b/gnu/packages/pep.scm
@@ -244,7 +244,7 @@ ENGINE_INC_PATH=~a/include
`(("boost-python" ,boost-with-python3)
("libpepadapter" ,libpepadapter)
("pep-engine" ,pep-engine)
- ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("util-linux" ,util-linux "lib"))) ;; uuid.h
(home-page "https://pep.foundation/")
(synopsis "Python adapter for p≡p (pretty Easy Privacy)")
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 30062f43c5..6906f7050c 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -58,7 +58,7 @@
(native-inputs
`(("python-pep517" ,python-pep517)
("python-setuptools" ,python-setuptools)
- ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("python-coverage" ,python-coverage)
("python-coveralls" ,python-coveralls)
("python-pyannotate" ,python-pyannotate)
@@ -86,7 +86,7 @@ were a single file.")
(propagated-inputs
`(("python-cffi" ,python-cffi)
("python-toml" ,python-toml)
- ("python-setuptools-scm" ,python-setuptools-scm/next)))
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(native-inputs
`(("python-setuptools" ,python-setuptools)
("python-coverage" ,python-coverage)
@@ -114,7 +114,7 @@ Jump conversion filter by CFFI for Python.")
`(("python-cffi" ,python-cffi)))
(native-inputs
`(("python-setuptools" ,python-setuptools)
- ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("python-pep517" ,python-pep517)
("python-coverage" ,python-coverage)
("python-pytest" ,python-pytest)
@@ -148,7 +148,7 @@ several possible methods.")
("python-zstandard" ,python-zstandard)))
(native-inputs
`(("python-setuptools" ,python-setuptools)
- ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("python-coverage" ,python-coverage)
("python-coveralls" ,python-coveralls)
("python-libarchive-c" ,python-libarchive-c)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 417630ad74..2da0471aa5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6338,7 +6338,7 @@ the OleFileIO module from PIL, the Python Image Library.")
(native-inputs
`(("pybind11" ,pybind11)
("python-setuptools" ,python-setuptools)
- ("python-setuptools-scm" ,python-setuptools-scm/next)
+ ("python-setuptools-scm" ,python-setuptools-scm)
("python-setuptools-scm-git-archive" ,python-setuptools-scm-git-archive)
("python-toml" ,python-toml)
("python-wheel" ,python-wheel)))
@@ -7277,18 +7277,6 @@ child application and control it as if a human were typing commands.")
them as the version argument or in a SCM managed file.")
(license license:expat)))
-;; TODO: Merge with 'python-setuptools-scm' on the next rebuild cycle.
-(define-public python-setuptools-scm/next
- (package
- (inherit python-setuptools-scm)
- (version "5.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "setuptools_scm" version))
- (sha256
- (base32 "0ahlrxxkx2xhmxskx57gc96w3bdndflxx30304ihvm7ds136nny8"))))))
-
(define-public python2-setuptools-scm
(package-with-python2 python-setuptools-scm))