summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-04 16:34:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-04 16:34:47 +0100
commit5aaf67fc1f2c9eca1ef36746dd57721f2e0abd5f (patch)
tree7c57c8380ee1393403b97eb70ef8753027bc2384 /gnu
parentb317895f58b4f8d384887605f150756ba5a1fad7 (diff)
downloadguix-patches-5aaf67fc1f2c9eca1ef36746dd57721f2e0abd5f.tar
guix-patches-5aaf67fc1f2c9eca1ef36746dd57721f2e0abd5f.tar.gz
gnu: Add r-tinytest.
* gnu/packages/cran.scm (r-tinytest): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 501616c880..b229e0e318 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4975,6 +4975,41 @@ functions to compile LaTeX documents, and install missing LaTeX packages
automatically.")
(license license:expat)))
+(define-public r-tinytest
+ (package
+ (name "r-tinytest")
+ (version "1.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tinytest" version))
+ (sha256
+ (base32
+ "1asryjrah3fj39gg0c6yxgpr142j5bg2n990v7q8r0a5pb8gcr45"))))
+ (properties `((upstream-name . "tinytest")))
+ (build-system r-build-system)
+ (home-page "https://github.com/markvanderloo/tinytest")
+ (synopsis "Lightweight unit testing framework")
+ (description
+ "This package provides a lightweight unit testing framework. Main
+features:
+
+@enumerate
+@item install tests with the package;
+@item test results are treated as data that can be stored and manipulated;
+@item test files are R scripts interspersed with test commands, that can be
+ programmed over;
+@item fully automated build-install-test sequence for packages;
+@item skip tests when not run locally (e.g. on CRAN);
+@item flexible and configurable output printing;
+@item compare computed output with output stored with the package;
+@item run tests in parallel;
+@item extensible by other packages;
+@item report side effects.
+@end enumerate
+")
+ (license license:gpl3)))
+
(define-public r-network
(package
(name "r-network")