summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 22:09:20 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:45 +0100
commit5a0fc6953a0235b9913fff9047f8be6e59314c98 (patch)
treeb3a681bdbd27d622fcb0501aecea563d6cafeb72 /gnu
parentec9ce95155771df8578a7d652b283dffad7089e4 (diff)
downloadguix-patches-5a0fc6953a0235b9913fff9047f8be6e59314c98.tar
guix-patches-5a0fc6953a0235b9913fff9047f8be6e59314c98.tar.gz
gnu: Add kgoldrunner.
* gnu/packages/games.scm (kgoldrunner): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c4f5657b74..b7d2371e43 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8515,3 +8515,45 @@ player moves a ball, three more balls are added to the board.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kgoldrunner
+ (package
+ (name "kgoldrunner")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version "/src/kgoldrunner-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "16rcvq796r3asz4v4ap75xvwnxd3dd2nsq5r9vxvzl6rrf1w9bj4"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Action and puzzle solving game")
+ (description "KGoldrunner is an action game where the hero runs through a
+maze, climbs stairs, dig holes and dodges enemies in order to collect all the
+gold nuggets and escape to the next level. Your enemies are also after the
+gold. Worse still, they are after you!.
+
+KGoldrunner is a fast-paced platform game where the player must navigate a
+maze while collecting gold nuggets and avoiding enemies. A variety of level
+packs are included, as well as an editor to create new levels.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))