summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-27 22:54:09 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-29 14:02:46 -0500
commit596104f8071aa4b93a97b8780f5e85d76849ef2c (patch)
treea50dede17fe8d634b45806529934c3adf7dc7953 /gnu
parent4035c2e402eb7ff42ecceacd927f34997367cdf5 (diff)
downloadguix-patches-596104f8071aa4b93a97b8780f5e85d76849ef2c.tar
guix-patches-596104f8071aa4b93a97b8780f5e85d76849ef2c.tar.gz
gnu: Add python-iniconfig.
* gnu/packages/python-xyz.scm (python-iniconfig): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 931786846a..ee3256197c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15536,6 +15536,31 @@ in other versions.")
(define-public python2-configparser
(package-with-python2 python-configparser))
+(define-public python-iniconfig
+ (package
+ (name "python-iniconfig")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "iniconfig" version))
+ (sha256
+ (base32
+ "0ckzngs3scaa1mcfmsi1w40a1l8cxxnncscrxzjjwjyisx8z0fmw"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/RonnyPfannschmidt/iniconfig")
+ (synopsis "Simple INI-file parser")
+ (description "The @code{iniconfig} package provides a small and simple
+INI-file parser module having a unique set of features; @code{iniconfig}
+@itemize
+@item maintains the order of sections and entries;
+@item supports multi-line values with or without line-continuations;
+@item supports \"#\" comments everywhere;
+@item raises errors with proper line-numbers;
+@item raises an error when two sections have the same name.
+@end itemize")
+ (license license:expat)))
+
(define-public python-mamba
(package
(name "python-mamba")