summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:17:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:38 +0200
commit57f5e3d4421a3345f0860394b4470c4f4d7c68d4 (patch)
treeaf394bd941c297261189d980db5f8bb27fbb15a6 /gnu
parentbef9e04eebafced2731e7d08b3eda8bacff0e3f4 (diff)
downloadguix-patches-57f5e3d4421a3345f0860394b4470c4f4d7c68d4.tar
guix-patches-57f5e3d4421a3345f0860394b4470c4f4d7c68d4.tar.gz
gnu: Add texlive-metauml.
* gnu/packages/tex.scm (texlive-metauml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 257beb7591..abc95e291a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5560,6 +5560,25 @@ other contexts as well.")
second as RGB.")
(license license:gpl3+)))
+(define-public texlive-metauml
+ (package
+ (name "texlive-metauml")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/metauml/" "metapost/metauml/")
+ (base32
+ "01hs234mjqnr39zm7jl6dpbm5w0k4p73pr0aj35ii0dhakln2jsy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/metauml")
+ (synopsis "MetaPost library for typesetting UML diagrams")
+ (description
+ "MetaUML is a MetaPost library for typesetting UML diagrams, which
+provides a usable, human-friendly textual notation for UML, offering now
+support for class, package, activity, state, and use case diagrams.")
+ (license license:gpl3+)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")