summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-31 14:56:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-31 23:13:45 -0400
commit5755aa61f6b7f7c1aef76a127bc9abd920641c93 (patch)
tree00aeab84ded49d8e160a49377752ecef3168aa87 /gnu
parent15fbb963b6feeb6e835c633c9200a7a78b6c5f06 (diff)
downloadguix-patches-5755aa61f6b7f7c1aef76a127bc9abd920641c93.tar
guix-patches-5755aa61f6b7f7c1aef76a127bc9abd920641c93.tar.gz
gnu: Add python-types-protobuf.
* gnu/packages/python-xyz.scm (python-types-protobuf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b649991cd5..bf46bdc854 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29427,6 +29427,24 @@ very small subset the Python stubs contained in the complete @code{typeshed}
collection.")
(license license:asl2.0)))
+(define-public python-types-protobuf
+ (package
+ (name "python-types-protobuf")
+ (version "3.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-protobuf" version))
+ (sha256
+ (base32
+ "000f8n6d4ilihiaf590k73rx3327jh8ima5q5dpxlwz3frj45qrn"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for @code{protobuf}")
+ (description "This package contains typing stubs for @code{protobuf}, a
+very small subset the Python stubs contained in the complete @code{typeshed}
+collection.")
+ (license license:asl2.0)))
+
(define-public python-types-pytz
(package
(name "python-types-pytz")