summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-09-24 22:44:55 +1000
committerLudovic Courtès <ludo@gnu.org>2016-10-01 14:34:31 +0200
commit56ee1d2015e9b2c55d34f19c70b06eefe8a20c76 (patch)
tree4f58f684d665eeac1348ddda9c535e7ee1ea7872 /gnu
parent8d29bfa9fcd200aec161ea86da1485d0abc68890 (diff)
downloadguix-patches-56ee1d2015e9b2c55d34f19c70b06eefe8a20c76.tar
guix-patches-56ee1d2015e9b2c55d34f19c70b06eefe8a20c76.tar.gz
gnu: perl: Use configure-flags.
* gnu/packages/perl.scm (perl)[arguments]: Use configure-flags. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 63baed8d35..fbccff2550 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -61,6 +61,19 @@
(build-system gnu-build-system)
(arguments
'(#:tests? #f
+ #:configure-flags
+ (let ((out (assoc-ref %outputs "out"))
+ (libc (assoc-ref %build-inputs "libc")))
+ (list
+ (string-append "-Dprefix=" out)
+ (string-append "-Dman1dir=" out "/share/man/man1")
+ (string-append "-Dman3dir=" out "/share/man/man3")
+ "-de" "-Dcc=gcc"
+ "-Uinstallusrbinperl"
+ "-Dinstallstyle=lib/perl5"
+ "-Duseshrplib"
+ (string-append "-Dlocincpth=" libc "/include")
+ (string-append "-Dloclibpth=" libc "/lib")))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'setup-configure
@@ -76,23 +89,10 @@
(("-std=c89")
"-std=gnu89"))
#t))
- (replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (libc (assoc-ref inputs "libc")))
- (zero?
- (system* "./Configure"
- (string-append "-Dprefix=" out)
- (string-append "-Dman1dir=" out "/share/man/man1")
- (string-append "-Dman3dir=" out "/share/man/man3")
- "-de" "-Dcc=gcc"
- "-Uinstallusrbinperl"
- "-Dinstallstyle=lib/perl5"
- "-Duseshrplib"
- (string-append "-Dlocincpth=" libc "/include")
- (string-append "-Dloclibpth=" libc "/lib"))))))
-
+ (replace 'configure
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ (format #t "Perl configure flags: ~s~%" configure-flags)
+ (zero? (apply system* "./Configure" configure-flags))))
(add-before
'strip 'make-shared-objects-writable
(lambda* (#:key outputs #:allow-other-keys)