summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:37 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:55 +0200
commit55e88a27592b5b453df9511fe55d9311e2895efd (patch)
treed4dfaabbbc7ade638ade13c7a309589c0fba5969 /gnu
parentd38a0024710d83d829a1057b9445c7864346c73c (diff)
downloadguix-patches-55e88a27592b5b453df9511fe55d9311e2895efd.tar
guix-patches-55e88a27592b5b453df9511fe55d9311e2895efd.tar.gz
gnu: julia-reversediff: Don't ask to run tests when cross-compiling.
* gnu/packages/julia-xyz.scm (julia-reversediff)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4fa711b808..a4b3fe2a66 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4660,7 +4660,8 @@ can be avoided.")
;; Expression: hash(tr_float, hash(1)) === hash(v_float, hash(1))
;; MethodError: no method matching decompose(::ReverseDiff.TrackedReal{Float64, Float64, Nothing})
;; Disable as stopgap.
- (list #:tests? (not (target-x86-32?))))
+ (list #:tests? (not (or (%current-target-system)
+ (target-x86-32?)))))
(propagated-inputs
(list julia-diffresults
julia-diffrules