summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-20 16:15:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-20 16:21:06 +0100
commit549332027428d2ecffce33bf3af228026573546a (patch)
tree8c959f253e5144a5c3d33c91d42c135367ad0326 /gnu
parentaf184b68e78aa51b6ff50b7327dfbbdb1d6e6843 (diff)
downloadguix-patches-549332027428d2ecffce33bf3af228026573546a.tar
guix-patches-549332027428d2ecffce33bf3af228026573546a.tar.gz
gnu: iproute2: Update to 5.0.0.
* gnu/packages/linux.scm (iproute): Update to 5.0.0. [inputs, native-inputs]: Order alphabetically.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 34af81b469..311bc6fa5f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1254,7 +1254,7 @@ that the Ethernet protocol is much simpler than the IP protocol.")
(define-public iproute
(package
(name "iproute2")
- (version "4.20.0")
+ (version "5.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1262,10 +1262,11 @@ that the Ethernet protocol is much simpler than the IP protocol.")
version ".tar.xz"))
(sha256
(base32
- "1a7xyvqjxfnm7rk21amm0xgxa38clg7q7cmc4dmlg27q81mambf8"))))
+ "1fi03lb8dqr8hq633gcqsf6228vsvysxms075j1yyl4nlc17616z"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no test suite
+ `( ;; There is a test suite, but it wants network namespaces and sudo.
+ #:tests? #f
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "DESTDIR="
(string-append "BASH_COMPDIR=" out
@@ -1285,12 +1286,15 @@ that the Ethernet protocol is much simpler than the IP protocol.")
(("^.*ARPDDIR.*$") ""))
#t)))))
(inputs
- `(("iptables" ,iptables)
- ("db4" ,bdb)))
+ `(("db4" ,bdb)
+ ("iptables" ,iptables)))
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("bison" ,bison)
("flex" ,flex)
- ("bison" ,bison)))
+ ("pkg-config" ,pkg-config)))
+ ;; For tests.
+ ;; ("libmnl" ,libmnl)
+ ;; ("util-linux" ,util-linux)
(home-page
"https://wiki.linuxfoundation.org/networking/iproute2")
(synopsis