summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2021-04-12 10:22:55 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-04-12 15:16:57 +0300
commit5414617120f632b94838eb6a27295cd04c065cee (patch)
treebbb841da6caf79cd231123884213cf3e5601ef1b /gnu
parente1a465209925c43871ce581c2752ae620fbedd3a (diff)
downloadguix-patches-5414617120f632b94838eb6a27295cd04c065cee.tar
guix-patches-5414617120f632b94838eb6a27295cd04c065cee.tar.gz
gnu: python-mechanicalsoup: Update to 1.0.0.
* gnu/packages/python-web.scm (python-mechanicalsoup): Update to 1.0.0. [arguments]: Enable tests. [native-inputs]: Add python-pytest-flake8, python-pytest-httpbin, python-pytest-cov, python-pytest-mock, python-pytest-runner, python-requests-mock. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c79fa1bfc4..4c5a005629 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -795,29 +796,26 @@ object graph to and from JSON.")
(define-public python-mechanicalsoup
(package
(name "python-mechanicalsoup")
- (version "0.11.0")
+ (version "1.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "MechanicalSoup" version))
(sha256
- (base32 "0k59wwk75q7nz6i6gynvzhagy02ql0bv7py3qqcwgjw7607yq4i7"))))
+ (base32 "01sddjxy3rznh63hnl5lbv1hhk6xyiviwmkiw4x7v4ap35fb3lrp"))))
(build-system python-build-system)
- (arguments
- ;; TODO: Enable tests when python-flake8@3.5 hits master.
- `(#:tests? #f))
(propagated-inputs
`(("python-beautifulsoup4" ,python-beautifulsoup4)
("python-lxml" ,python-lxml)
("python-requests" ,python-requests)
("python-six" ,python-six)))
- ;; (native-inputs
- ;; ;; For tests.
- ;; `(("python-pytest-flake8" ,python-pytest-flake8)
- ;; ("python-pytest-httpbin" ,python-pytest-httpbin)
- ;; ("python-pytest-mock" ,python-pytest-mock)
- ;; ("python-pytest-runner" ,python-pytest-runner)
- ;; ("python-requests-mock" ,python-requests-mock)))
+ (native-inputs
+ `(("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-flake8" ,python-pytest-flake8)
+ ("python-pytest-httpbin" ,python-pytest-httpbin)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-requests-mock" ,python-requests-mock)))
(home-page "https://mechanicalsoup.readthedocs.io/")
(synopsis "Python library for automating website interaction")
(description