summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-25 03:26:00 +0000
committerLeo Famulari <leo@famulari.name>2021-04-25 14:49:56 -0400
commit50847139f4e3adc30370997dfb280c93f512fcbd (patch)
tree6de4b8533979a58aac067590a138f76df3828bd9 /gnu
parentc0fa0efe8a42db051ff42ec014141a6e2a359af6 (diff)
downloadguix-patches-50847139f4e3adc30370997dfb280c93f512fcbd.tar
guix-patches-50847139f4e3adc30370997dfb280c93f512fcbd.tar.gz
gnu: Add python-pyqtgraph.
* gnu/packages/python-xyz.scm (python-pyqtgraph): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ebc512670..df2d1e9245 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12581,6 +12581,58 @@ ISO 8859, etc.).")
(description "AnyQt is a PyQt4/PyQt5 compatibility layer.")
(license license:gpl3)))
+(define-public python-pyqtgraph
+ (package
+ (name "python-pyqtgraph")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyqtgraph" version))
+ (sha256
+ (base32 "0kc7ncv0lr3spni29i9g8nszyr4xinswqi2zzs6v8kqqi593pvyj"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-home-and-qpa
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t))
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "-k"
+ ;; These tests try to download online data.
+ (string-append "not test_PolyLineROI"
+ " and not test_getArrayRegion_axisorder"
+ " and not test_getArrayRegion"
+ " and not test_PlotCurveItem"
+ " and not test_NonUniformImage_colormap"
+ " and not test_NonUniformImage_lut"
+ " and not test_ImageItem_axisorder"
+ " and not test_ImageItem")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-xdist" ,python-pytest-xdist)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (propagated-inputs
+ `(("python-h5py" ,python-h5py)
+ ("python-numpy" ,python-numpy)
+ ("python-pyopengl" ,python-pyopengl)
+ ("python-scipy" ,python-scipy)
+ ("python-pyqt" ,python-pyqt)))
+ (home-page "http://www.pyqtgraph.org")
+ (synopsis "Scientific graphics and GUI library for Python")
+ (description
+ "PyQtGraph is a Pure-python graphics library for PyQt5, PyQt6, PySide2
+and PySide6. It is intended for use in mathematics, scientific or engineering
+applications.")
+ (license license:expat)))
+
(define-public python-editor
(package
(name "python-editor")