summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-10-18 17:33:03 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:50 +0100
commit4ff5cd6b0645a06a6542834f6ff83d725ce61b5c (patch)
treedde6d73bce060d4b4e41c05c6def072c965e8d18 /gnu
parent2a32dedfbfa262ad782421064e5be6f1403bcb9f (diff)
downloadguix-patches-4ff5cd6b0645a06a6542834f6ff83d725ce61b5c.tar
guix-patches-4ff5cd6b0645a06a6542834f6ff83d725ce61b5c.tar.gz
gnu: aws-c-cal: Update to 0.5.12.
* gnu/packages/c.scm (aws-c-cal): Update to 0.5.12. [arguments]: Fix CMAKE_PREFIX_PATH. [source]: Remove patch. * gnu/packages/patches/aws-c-cal-cmake-prefix.patch: Delete file. * gnu/local.mk: Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/c.scm10
-rw-r--r--gnu/packages/patches/aws-c-cal-cmake-prefix.patch13
3 files changed, 6 insertions, 18 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9986b01537..a1cc397f3b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -872,7 +872,6 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-auth-cmake-prefix.patch \
%D%/packages/patches/aws-c-auth-disable-networking-tests.patch\
- %D%/packages/patches/aws-c-cal-cmake-prefix.patch \
%D%/packages/patches/aws-c-compression-cmake-prefix.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 1479cf847d..a537988abe 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -669,7 +669,8 @@ event-driven, asynchronous network application protocols.")
(define-public aws-c-cal
(package
(name "aws-c-cal")
- (version "0.5.11")
+ ; Update only when updating aws-crt-cpp.
+ (version "0.5.12")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -678,12 +679,13 @@ event-driven, asynchronous network application protocols.")
(file-name (git-file-name name version))
(sha256
(base32
- "0rqqk4n56h8sf4q070rhgjwas04j8h0vq4wl1alq5l1rqq72qqdf"))
- (patches (search-patches "aws-c-cal-cmake-prefix.patch"))))
+ "09zqf610x4g2mcjcaf9nh88k6dkw14pi721yr8hxb5rmsx7rlfrb"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
+ (list "-DBUILD_SHARED_LIBS=ON"
+ (string-append "-DCMAKE_PREFIX_PATH="
+ (assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-c-common" ,aws-c-common)))
(inputs
diff --git a/gnu/packages/patches/aws-c-cal-cmake-prefix.patch b/gnu/packages/patches/aws-c-cal-cmake-prefix.patch
deleted file mode 100644
index 1ee7aa851d..0000000000
--- a/gnu/packages/patches/aws-c-cal-cmake-prefix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -10,6 +10,10 @@ endif()
-
- option(BYO_CRYPTO "Set this if you want to provide your own cryptography implementation. This will cause the defaults to not be compiled." OFF)
-
-+if (DEFINED ENV{CMAKE_PREFIX_PATH})
-+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
-+endif()
-+
- if (DEFINED CMAKE_PREFIX_PATH)
- file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
- endif()