summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-24 16:13:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-24 16:13:35 +0300
commit4ea6161046e664470b036f4692ea115e33ef6003 (patch)
treeabec824cb6b218206d162a6674f21faa2b7ca3c9 /gnu
parent67ac4348d4f4631b65201f66e0ba56f54143ad1b (diff)
downloadguix-patches-4ea6161046e664470b036f4692ea115e33ef6003.tar
guix-patches-4ea6161046e664470b036f4692ea115e33ef6003.tar.gz
gnu: python-matplotlib: Don't hardcode python version.
* gnu/packages/python-xyz.scm (python-matplotlib)[arguments]: In custom 'install-jquery-ui phase programmatically get the version of python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 954536b283..25f986e9b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5563,8 +5563,11 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
#t))
(add-before 'install 'install-jquery-ui
(lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((dir (string-append (assoc-ref outputs "out")
- "/lib/python3.7/site-packages/matplotlib/backends/web_backend/")))
+ (let* ((python-version (python-version
+ (assoc-ref inputs "python")))
+ (dir (string-append (assoc-ref outputs "out")
+ "/lib/python" python-version "/site-packages"
+ "/matplotlib/backends/web_backend/")))
(mkdir-p dir)
(invoke "unzip"
(assoc-ref inputs "jquery-ui")