summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 22:20:10 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:17 +0100
commit4d078ed7104b523a8861a73d48a60b126307b75e (patch)
tree901d4df40f7da917dd1e85eb7d5daba37d017ad8 /gnu
parent9f6b44b123d85fae78acfcb58e8af3895a5a6dba (diff)
downloadguix-patches-4d078ed7104b523a8861a73d48a60b126307b75e.tar
guix-patches-4d078ed7104b523a8861a73d48a60b126307b75e.tar.gz
gnu: python-texttable: Update to 1.6.4.
* gnu/packages/python-xyz.scm (python-texttable): Update to 1.6.4. [arguments]: Respect #:tests? in check phase and increase verbosity.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index add2908072..e53ba67cdc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12993,20 +12993,21 @@ the standard library.")
(define-public python-texttable
(package
(name "python-texttable")
- (version "1.6.2")
+ (version "1.6.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "texttable" version))
(sha256
(base32
- "1x5l77akfc20x52jma9573qp8l8r07q103pm4l0pbizvh4vp1wzg"))))
+ "1sbn821394rix6xgj3zqk743pj6nqm1qz81zgis2bcpp2ng7pvj2"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "pytest" "tests.py"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "pytest" "-vv" "tests.py")))))))
(native-inputs
(list python-pytest))
(home-page "https://github.com/foutaise/texttable/")