summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 20:37:08 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:17 +0100
commit4ccb22802c6a7ba122dd95d01e569c613c313ddf (patch)
treed9e6bffe7f4ffd1727fe1493fe1f17f8d4323137 /gnu
parentd08eb54acb4d6461ab84934534dcb5adc4614173 (diff)
downloadguix-patches-4ccb22802c6a7ba122dd95d01e569c613c313ddf.tar
guix-patches-4ccb22802c6a7ba122dd95d01e569c613c313ddf.tar.gz
gnu: python-websocket-client: Update to 1.2.3.
* gnu/packages/python-web.scm (python-websocket-client): Update to 1.2.3. [arguments]: Override check phase. [native-inputs]: Add PYTHON-WEBSOCKETS and PYTHON-PYTEST. [propagated-inputs]: Remove. [properties]: Remove. (python2-websocket-client): Remove variable. (python-websocket-client-0.59): New variable. * gnu/packages/docker.scm (docker-compose)[inputs]: Change from PYTHON-WEBSOCKET-CLIENT to PYTHON-WEBSOCKET-CLIENT-0.59.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/docker.scm2
-rw-r--r--gnu/packages/python-web.scm33
2 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index dc3b8ec69f..3f52f4f8db 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -126,7 +126,7 @@ client.")
python-requests
python-six
python-texttable
- python-websocket-client))
+ python-websocket-client-0.59))
(home-page "https://www.docker.com/")
(synopsis "Multi-container orchestration for Docker")
(description "Docker Compose is a tool for defining and running
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 220a93f344..1c2211e6dd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2414,13 +2414,13 @@ verification of the SSL peer.")
(define-public python-websocket-client
(package
(name "python-websocket-client")
- (version "0.59.0") ; tests hang on newer versions
+ (version "1.2.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "websocket-client" version))
(sha256
- (base32 "0p0cz2mdissq7iw1n7jrmsfir0jfmgs1dvnpnrx477ffx9hbsxnk"))))
+ (base32 "1xba9z6b211pandrlk2l5p8wj6gn7yfkpq1sxfbqjl6c19n8258k"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2429,26 +2429,29 @@ verification of the SSL peer.")
(lambda _
;; This test requires networking.
(substitute* "websocket/tests/test_http.py"
- (("def testConnect") "def _testConnect")))))))
+ (("def testConnect") "def _testConnect"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "websocket/tests")))))))
(native-inputs
- (list python-pysocks))
- (propagated-inputs
- (list python-six))
+ (list python-pysocks python-pytest python-websockets))
(home-page "https://github.com/websocket-client/websocket-client")
(synopsis "WebSocket client for Python")
(description "The Websocket-client module provides the low level APIs for
WebSocket usage in Python programs.")
- (properties `((python2-variant . ,(delay python2-websocket-client))))
(license license:lgpl2.1+)))
-(define-public python2-websocket-client
- (let ((base (package-with-python2
- (strip-python2-variant python-websocket-client))))
- (package/inherit base
- (native-inputs
- `(("python2-backport-ssl-match-hostname"
- ,python2-backport-ssl-match-hostname)
- ,@(package-native-inputs base))))))
+(define-public python-websocket-client-0.59
+ (package
+ (inherit python-websocket-client)
+ (version "0.59.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "websocket-client" version))
+ (sha256
+ (base32 "0p0cz2mdissq7iw1n7jrmsfir0jfmgs1dvnpnrx477ffx9hbsxnk"))))))
(define-public python-purl
(package