summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-12-18 21:24:16 +0900
committerMathieu Othacehe <m.othacehe@gmail.com>2018-12-21 10:54:09 +0100
commit4b33a74138740101042c31bef304b8ba35e81126 (patch)
treea2e7bd4c02b0dada9e0fd39654a2e0b99673ba9c /gnu
parent39c676c4a3507863f4edf20b225ace4cbf646ed6 (diff)
downloadguix-patches-4b33a74138740101042c31bef304b8ba35e81126.tar
guix-patches-4b33a74138740101042c31bef304b8ba35e81126.tar.gz
gnu: Add emacs-wordnut.
* gnu/packages/patches/emacs-wordnut-require-adaptive-wrap.patch: New file. * gnu/local.mk (dist_patch_DATA): Add previous file. * gnu/packages/emacs.scm (emacs-wordnut): New package.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs.scm26
-rw-r--r--gnu/packages/patches/emacs-wordnut-require-adaptive-wrap.patch20
3 files changed, 47 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5f6826e27a..e2cac7ffed 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -674,6 +674,7 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
%D%/packages/patches/emacs-source-date-epoch.patch \
%D%/packages/patches/emacs-realgud-fix-configure-ac.patch \
+ %D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
%D%/packages/patches/erlang-man-path.patch \
%D%/packages/patches/eudev-rules-directory.patch \
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 52f4018c27..9d16dc3dc6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12828,3 +12828,29 @@ testing Emacs Lisp code. It allows to group related tests so they can share
common set-up and tear-down code, and allows the programmer to \"spy\" on
functions to ensure they are called with the right arguments during testing.")
(license license:gpl3+)))
+
+(define-public emacs-wordnut
+ (let ((commit "feac531404041855312c1a046bde7ea18c674915")
+ (revision "0"))
+ (package
+ (name "emacs-wordnut")
+ (version (git-version "0.1" revision commit))
+ (home-page "https://github.com/gromnitsky/wordnut")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (sha256
+ (base32
+ "1jl0b6g64a9w0q7bfvwha67vgws5xd15b7mkfyb5gkz3pymqhfxn"))
+ (patches
+ (search-patches "emacs-wordnut-require-adaptive-wrap.patch"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("wordnet" ,wordnet)
+ ("emacs-adaptive-wrap" ,emacs-adaptive-wrap)))
+ (synopsis "Major mode for WordNet")
+ (description "This Emacs package provides an interface for
+@code{wordnet}. Features include completion, if the query is not found
+too ambiguous and navigation in the result buffer.")
+ (license license:gpl3+))))
diff --git a/gnu/packages/patches/emacs-wordnut-require-adaptive-wrap.patch b/gnu/packages/patches/emacs-wordnut-require-adaptive-wrap.patch
new file mode 100644
index 0000000000..be10254c33
--- /dev/null
+++ b/gnu/packages/patches/emacs-wordnut-require-adaptive-wrap.patch
@@ -0,0 +1,20 @@
+Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+
+This patch forces the use of adaptive-wrap. This feature is optional but we
+prefer to enable it by default.
+
+diff --git a/wordnut.el b/wordnut.el
+index 0ae86ad..72f9221 100644
+--- a/wordnut.el
++++ b/wordnut.el
+@@ -4,6 +4,7 @@
+ (require 'subr-x)
+ (require 'outline)
+ (require 'imenu)
++(require 'adaptive-wrap)
+
+ (require 'wordnut-history)
+
+--
+2.17.1
+