summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 08:09:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:42 +0200
commit4af17a752703885cf8835669468607902eebd86d (patch)
treedc8f60a8011554e84780ff0a114febe262300fae /gnu
parent49928a5dc26f6d42b09826a034f6e7d88a892c21 (diff)
downloadguix-patches-4af17a752703885cf8835669468607902eebd86d.tar
guix-patches-4af17a752703885cf8835669468607902eebd86d.tar.gz
gnu: texlive-latex-g-brief -> texlive-g-brief.
* gnu/packages/tex.scm (texlive-g-brief): New variable. (texlive-latex-g-brief): Deprecate variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 18 insertions, 19 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cd8d0d218c..7648a948e0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5933,35 +5933,34 @@ course of the framed/shaded matter. There is also a command
(define-deprecated-package texlive-latex-framed texlive-framed)
-(define-public texlive-latex-g-brief
+(define-public texlive-g-brief
(package
- (name "texlive-latex-g-brief")
+ (name "texlive-g-brief")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "g-brief"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1br4kv9y17cvngp83ykpvy7gy3jqfan5plk7sggcgbdfhndi5dsr"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/g-brief/"
+ "source/latex/g-brief/"
+ "tex/latex/g-brief/")
+ (base32
+ "0sicgf3wjw5jymh5xjxby2hsilakhw2lqgywx0f2zax1z854xc2m")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments
- '(#:tex-directory "latex/g-brief"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-generated-file
- (lambda _
- (delete-file "g-brief.drv")
- #t)))))
+ (propagated-inputs
+ (list texlive-babel
+ texlive-eurosym
+ texlive-marvosym))
(home-page "https://www.ctan.org/pkg/g-brief")
(synopsis "Letter document class")
(description
"This package is designed for formatting formless letters in German; it
can also be used for English (by those who can read the documentation). There
-are LaTeX 2.09 @code{documentstyle} and LaTeX 2e class files for both an
-\"old\" and a \"new\" version of g-brief.")
+are LaTeX 2.09 @code{documentstyle} and LaTeX 2e class files for both an old
+and a new version of @code{g-brief}.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-g-brief texlive-g-brief)
+
(define-public texlive-latex-galois
(package
(name "texlive-latex-galois")