summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-03 17:30:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 02:38:25 -0400
commit4acd1213a360fe2a8b012245f18c0ad886e4d97e (patch)
tree2610ef3f41e9231b83da7c5e326b27881dbda719 /gnu
parent0fbaf75b1a39fbbf1dd9b3733376ebb310cde177 (diff)
downloadguix-patches-4acd1213a360fe2a8b012245f18c0ad886e4d97e.tar
guix-patches-4acd1213a360fe2a8b012245f18c0ad886e4d97e.tar.gz
gnu: Add rust-fwdansi-1.
* gnu/packages/crates-io.scm (rust-fwdansi-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dfca6de341..e6f01e8b93 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16156,6 +16156,32 @@ futures-rs library.")
(description "This package provides a fuzzy matching library in Rust.")
(license license:expat)))
+(define-public rust-fwdansi-1
+ (package
+ (name "rust-fwdansi")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fwdansi" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "027jz2x5fbi6rskic8sd6xx0mn03a7dnhwkpyz8hamg8gxwgbh88"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-memchr" ,rust-memchr-2)
+ ("rust-termcolor" ,rust-termcolor-1))
+ #:cargo-development-inputs
+ (("rust-proptest" ,rust-proptest-0.9))))
+ (home-page "https://github.com/kennytm/fwdansi")
+ (synopsis "ANSI escape codes to termcolor terminal library")
+ (description "This library can be used to forward a byte string with ANSI
+escape codes to a termcolor terminal.")
+ (license license:expat)))
+
(define-public rust-fxhash-0.2
(package
(name "rust-fxhash")