summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-11-18 15:45:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:35 +0100
commit47f6fd802e463c3a6d76a1960d0a40f30c8e58c5 (patch)
tree29aef36b1b900ff888e94e27f20af6a1afa60567 /gnu
parentcf6033ee6e45bb56c913b31289d61620971ca3be (diff)
downloadguix-patches-47f6fd802e463c3a6d76a1960d0a40f30c8e58c5.tar
guix-patches-47f6fd802e463c3a6d76a1960d0a40f30c8e58c5.tar.gz
gnu: Add r-ggalluvial.
* gnu/packages/cran.scm (r-ggalluvial): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9533006a26..05b1541ec7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -256,6 +256,35 @@ ordered indexed observations. It is particularly aimed at irregular time
series of numeric vectors/matrices and factors.")
(license license:gpl2+)))
+(define-public r-ggalluvial
+ (package
+ (name "r-ggalluvial")
+ (version "0.12.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggalluvial" version))
+ (sha256
+ (base32
+ "1qcpbb6h2znsq246n1291rxgfryiw24caghbk8acjzzfbdhdj8x1"))))
+ (properties `((upstream-name . "ggalluvial")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-rlang" ,r-rlang)
+ ("r-tidyr" ,r-tidyr)
+ ("r-tidyselect" ,r-tidyselect)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "http://corybrunson.github.io/ggalluvial/")
+ (synopsis "Alluvial plots for ggplot2")
+ (description "This package provides alluvial plots for @code{ggplot2}.
+Alluvial plots use variable-width ribbons and stacked bar plots to represent
+multi-dimensional or repeated-measures data with categorical or ordinal
+variables.")
+ (license license:gpl3)))
+
(define-public r-ggpmisc
(package
(name "r-ggpmisc")