summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-12 21:27:06 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-10 02:36:35 +0200
commit4792a0321a5163ed043d404925c8ab03efae1223 (patch)
tree922ea8514eb000321143e7d3cee14e71232d9b5a /gnu
parent1898eaa3357124034fecfbeb157b39b0f4e8c0c0 (diff)
downloadguix-patches-4792a0321a5163ed043d404925c8ab03efae1223.tar
guix-patches-4792a0321a5163ed043d404925c8ab03efae1223.tar.gz
gnu: python2-unittest2: Update to 1.1.0.
* gnu/packages/python.scm (python2-unittest2): Update to 1.1.0. * gnu/packages/patches/python2-unittest2-remove-argparse.patch: New file. * gnu/local.mk: Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python2-unittest2-remove-argparse.patch11
-rw-r--r--gnu/packages/python.scm9
3 files changed, 19 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b71b36024e..a866c9084a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -994,6 +994,7 @@ dist_patch_DATA = \
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
+ %D%/packages/patches/python2-unittest2-remove-argparse.patch \
%D%/packages/patches/qt4-ldflags.patch \
%D%/packages/patches/qtscript-disable-tests.patch \
%D%/packages/patches/quagga-reproducible-build.patch \
diff --git a/gnu/packages/patches/python2-unittest2-remove-argparse.patch b/gnu/packages/patches/python2-unittest2-remove-argparse.patch
new file mode 100644
index 0000000000..c96738757e
--- /dev/null
+++ b/gnu/packages/patches/python2-unittest2-remove-argparse.patch
@@ -0,0 +1,11 @@
+--- a/setup.py 2017-09-12 01:22:06.273997788 +0200
++++ b/setup.py 2017-09-12 01:22:14.297918757 +0200
+@@ -57,7 +57,7 @@
+ # Both install and setup requires - because we read VERSION from within the
+ # package, and the package also exports all the APIs.
+ # six for compat helpers
+-REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
++REQUIRES = ['six>=1.4', 'traceback2'],
+
+ params = dict(
+ name=NAME,
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fd08f1a469..f5e92d8890 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1843,7 +1843,7 @@ standard library.")
(define-public python2-unittest2
(package (inherit python-unittest2)
(name "python2-unittest2")
- (version "0.5.1")
+ (version "1.1.0")
(source
(origin
(method url-fetch)
@@ -1852,7 +1852,12 @@ standard library.")
version ".tar.gz"))
(sha256
(base32
- "0wbs4i4x3x7klr3v35ss6p9mcqz883i1xgcpkhvl7n2lyv6yhpda"))))
+ "0y855kmx7a8rnf81d3lh5lyxai1908xjp0laf4glwa4c8472m212"))
+ (patches
+ (search-patches "python2-unittest2-remove-argparse.patch"))))
+ (propagated-inputs
+ `(("python2-six" ,python2-six)
+ ("python2-traceback2" ,python2-traceback2)))
(arguments
`(#:python ,python-2
#:tests? #f)))) ; no setup.py test command