summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-13 16:30:26 +0100
committerMarius Bakke <marius@gnu.org>2021-12-13 23:28:57 +0100
commit467485a50a4a7261c245d36bc0778445ccc4d7f9 (patch)
tree410a2ac90223c7b9525e97a6e9735d871763bed0 /gnu
parent6dffced09ecda024e0884e352778c221ad066fd6 (diff)
downloadguix-patches-467485a50a4a7261c245d36bc0778445ccc4d7f9.tar
guix-patches-467485a50a4a7261c245d36bc0778445ccc4d7f9.tar.gz
gnu: Remove superfluous "linux-libre-headers" inputs.
This input is already propagated from glibc. * gnu/packages/chromium.scm (ungoogled-chromium)[inputs]: Remove LINUX-LIBRE-HEADERS-5.10. * gnu/packages/linux.scm (btrfs-progs)[native-inputs]: Likewise. * gnu/packages/accessibility.scm (brltty)[inputs]: Remove LINUX-LIBRE-HEADERS. * gnu/packages/graphics.scm (directfb)[inputs]: Likewise. * gnu/packages/gstreamer.scm (libdc1394)[inputs]: Likewise. * gnu/packages/linux.scm (python-evdev)[native-inputs]: Likewise. (bcc, bpftrace)[inputs]: Likewise. * gnu/packages/networking.scm (lksctp-tools)[inputs]: Likewise. * gnu/packages/video.scm (tslib)[inputs]: Likewise. * gnu/packages/web-browsers.scm (links)[native-inputs]: Likewise. * gnu/packages/cdrom.scm (cdrtools)[inputs]: Likewise. [arguments]: Adjust accordingly. * gnu/packages/lirc.scm (lirc)[inputs, arguments]: Likewise. * gnu/packages/vpn.scm (xl2tpd)[inputs, arguments]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/accessibility.scm1
-rw-r--r--gnu/packages/cdrom.scm4
-rw-r--r--gnu/packages/chromium.scm3
-rw-r--r--gnu/packages/graphics.scm1
-rw-r--r--gnu/packages/gstreamer.scm1
-rw-r--r--gnu/packages/linux.scm8
-rw-r--r--gnu/packages/lirc.scm3
-rw-r--r--gnu/packages/networking.scm2
-rw-r--r--gnu/packages/video.scm3
-rw-r--r--gnu/packages/vpn.scm4
-rw-r--r--gnu/packages/web-browsers.scm2
11 files changed, 7 insertions, 25 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 02159cbfcc..000f007015 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -182,7 +182,6 @@ terminals.")
("icu" ,icu4c)
("libbraille" ,libbraille)
("libpcre2" ,pcre2)
- ("linux-headers" ,linux-libre-headers)
("louis" ,liblouis)
("ncurses" ,ncurses)
("polkit" ,polkit)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 42571531e5..2a444eb7f6 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -318,8 +318,6 @@ format, commonly used for VCDs or disks with subchannel data.")
(patches (search-patches "cdrtools-3.01-mkisofs-isoinfo.patch"))))
(build-system gnu-build-system)
;; XXX cdrtools bundles a modified, relicensed early version of cdparanoia.
- (inputs
- `(("linux-headers" ,linux-libre-headers)))
(arguments
`(#:make-flags
(list "RM=rm" "LN=ln" "SYMLINK=ln -s"
@@ -336,7 +334,7 @@ format, commonly used for VCDs or disks with subchannel data.")
(lambda _
(substitute* "autoconf/configure"
(("/usr/src/linux")
- (assoc-ref %build-inputs "linux-headers")))
+ (assoc-ref %build-inputs "kernel-headers")))
#t))
(add-before 'build 'substitute-dirs
(lambda _
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 420c53cf36..c5282d59c3 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -874,9 +874,6 @@
("libxscrnsaver" ,libxscrnsaver)
("libxslt" ,libxslt)
("libxtst" ,libxtst)
- ;; Newer kernel headers are required for userfaultfd support; remove
- ;; after 'core-updates' merge.
- ("linux-libre-headers" ,linux-libre-headers-5.10)
("mesa" ,mesa)
("minizip" ,minizip)
("mit-krb5" ,mit-krb5)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 48844a1683..3f83c72599 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -182,7 +182,6 @@ framebuffer graphics, audio output and input event.")
("libcddb" ,libcddb)
("libdrm" ,libdrm)
("libtimidity" ,libtimidity)
- ("linux-headers" ,linux-libre-headers)
("mad" ,libmad)
("mng" ,libmng)
("mpeg2" ,libmpeg2)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 143e4e868e..87adb7c92a 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -155,7 +155,6 @@ and for middleware components.")
libraw1394
libusb
libxv
- linux-libre-headers
mesa
sdl
v4l-utils))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2e659836e2..1e39d3d078 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3879,8 +3879,6 @@ time.")
(sha256
(base32 "0kb3636yaw9l8xi8s184w0r0n9ic5dw3b8hx048jf9fpzss4kimi"))))
(build-system python-build-system)
- (native-inputs
- `(("kernel-headers" ,linux-libre-headers)))
(arguments
`(#:tests? #f ;no rule for tests
#:phases
@@ -5456,9 +5454,6 @@ and copy/paste text in the console and in xterm.")
("asciidoc" ,asciidoc)
("python" ,python)
("xmlto" ,xmlto)
- ;; Remove this input entirely when the default headers
- ;; version provides blk_zone.capacity (>= 5.9).
- ("linux-libre-headers" ,linux-libre-headers-5.10)
;; For building documentation.
("libxml2" ,libxml2)
("docbook-xsl" ,docbook-xsl)
@@ -8458,7 +8453,6 @@ headers.")
;; archives, only object files.
;; https://github.com/iovisor/bcc/issues/504
("elfutils" ,elfutils)
- ("linux-libre-headers" ,linux-libre-headers)
("luajit" ,luajit)
("python-wrapper" ,python-wrapper)))
(arguments
@@ -8533,7 +8527,7 @@ and above.")
(native-inputs
(list bison flex))
(inputs
- (list bcc clang-toolchain elfutils libbpf linux-libre-headers))
+ (list bcc clang-toolchain elfutils libbpf))
(arguments
`(#:tests? #f ;Tests require googletest sources.
#:configure-flags
diff --git a/gnu/packages/lirc.scm b/gnu/packages/lirc.scm
index 11cee04edd..1b8e8e37bd 100644
--- a/gnu/packages/lirc.scm
+++ b/gnu/packages/lirc.scm
@@ -69,7 +69,7 @@
(lambda* (#:key inputs #:allow-other-keys)
;; 'lirc-make-devinput' script assumes that linux headers
;; are placed in "/usr/...".
- (let ((headers (assoc-ref inputs "linux-headers")))
+ (let ((headers (assoc-ref inputs "kernel-headers")))
(substitute* "tools/lirc-make-devinput"
(("/usr/include") (string-append headers "/include"))))
#t))
@@ -89,7 +89,6 @@
(inputs
`(("libx11" ,libx11)
("libusb-compat" ,libusb-compat)
- ("linux-headers" ,linux-libre-headers)
("alsa-lib" ,alsa-lib)
("python" ,python)))
(home-page "https://www.lirc.org/")
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1ec1586fb3..b2518e1f8f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -494,8 +494,6 @@ performance across unpredictable networks, such as the Internet.")
(build-system gnu-build-system)
(native-inputs
(list autoconf automake libtool pkg-config))
- (inputs
- (list linux-libre-headers))
(synopsis
"@acronym{SCTP, Stream Control Transmission Protocol} helpers for Linux")
(description
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9b57d3cbb8..4b7251ee23 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -645,8 +645,7 @@ other software.")
(native-inputs
(list autoconf automake libtool pkg-config))
(inputs
- `(("linux-headers" ,linux-libre-headers)
- ("sdl2" ,sdl2)))
+ `(("sdl2" ,sdl2)))
(synopsis "Touchscreen access library")
(description "TSLib is a cross-platform library that provides access to
touchscreen devices and the ability to apply filters to their input events.")
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 358913d5db..ebaa13fa69 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -1083,10 +1083,10 @@ public keys and can roam across IP addresses.")
(("/usr/sbin/pppd")
(search-input-file inputs "/sbin/pppd")))
(setenv "KERNELSRC"
- (assoc-ref inputs "linux-libre-headers"))
+ (assoc-ref inputs "kernel-headers"))
#t)))
#:tests? #f)) ; no tests provided
- (inputs (list libpcap linux-libre-headers ppp))
+ (inputs (list libpcap ppp))
(home-page "https://www.xelerance.com/software/xl2tpd/")
(synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
(description
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 0fcb12d894..89abf0ac17 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -181,7 +181,7 @@ management, extensions such as advertisement blocker and colorful tabs.")
(invoke "./configure"
(string-append "--prefix=" out)
"--enable-graphics")))))))
- (native-inputs (list linux-libre-headers pkg-config))
+ (native-inputs (list pkg-config))
(inputs `(("gpm" ,gpm)
("libevent" ,libevent)
("libjpeg" ,libjpeg-turbo)