summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-09 15:55:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-09 16:41:12 +0200
commit44d66cf764df1a5f92e32c101bc88b20b8ac96b1 (patch)
treec5edf2ab8d25502a571abc220809c2007d8f9708 /gnu
parentc43c4d8b39df3b42cad1ff8db35d2bd9806e43d8 (diff)
downloadguix-patches-44d66cf764df1a5f92e32c101bc88b20b8ac96b1.tar
guix-patches-44d66cf764df1a5f92e32c101bc88b20b8ac96b1.tar.gz
gnu: facter: Update to 4.0.33.
* gnu/packages/admin.scm (facter): Update to 4.0.33.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d2d14b909a..f0bd22aa19 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -443,16 +443,16 @@ graphs and can export its output to different formats.")
(define-public facter
(package
(name "facter")
- (version "4.0.26")
+ (version "4.0.33")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/puppetlabs/facter-ng")
+ (url "https://github.com/puppetlabs/facter")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "0bab3by926gavbhkvp0in82vim575ybj8z6av3b12jdvla1s9rmz"))))
+ "0r9fi15cib4324ii4pniayjf27g51dka2skv9isiaj8y4wyhcq0v"))))
(build-system ruby-build-system)
(arguments
`(#:phases
@@ -470,7 +470,7 @@ graphs and can export its output to different formats.")
(add-after 'unpack 'embed-absolute-references
;; Refer to absolute executable file names to avoid propagation.
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "lib/resolvers" "\\.rb$")
+ (substitute* (find-files "lib/facter/resolvers" "\\.rb$")
(("execute\\('(which |)([^ ']+)" _ _ name)
(string-append "execute('" (or (which name)
name))))