summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-01-25 16:52:40 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-02-02 00:31:21 +0530
commit43af5f9d1961a89430d19a2e1509615586bc5dbd (patch)
tree475a2cc74dcfd9e5d7718254282bb571265bd831 /gnu
parentf6fe7da3721070f81a4b0378285cb6398b935c52 (diff)
downloadguix-patches-43af5f9d1961a89430d19a2e1509615586bc5dbd.tar
guix-patches-43af5f9d1961a89430d19a2e1509615586bc5dbd.tar.gz
gnu: Add emacs-mkmcc-gnuplot-mode.
* gnu/packages/emacs-xyz.scm (emacs-mkmcc-gnuplot-mode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b9ddaa7ad..163fe93543 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2018, 2019 Clément Lassieur <clement@lassieur.org>
@@ -12970,3 +12970,25 @@ comments.")
(description "This package provides an Emacs major mode which acts as a
front end to mpc, a client for the @dfn{Music Player Daemon} (MPD).")
(license license:gpl3+))))
+
+(define-public emacs-mkmcc-gnuplot-mode
+ (package
+ (name "emacs-mkmcc-gnuplot-mode")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mkmcc/gnuplot-mode")
+ (commit "601f6392986f0cba332c87678d31ae0d0a496ce7")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "14f0yh1rjqc3337j4sbqzfb7pjim2c8a7wk1a73xkrdkmjn82vgb"))))
+ (build-system emacs-build-system)
+ (home-page "https://mkmcc.github.io/software/gnuplot-mode.html")
+ (synopsis "Minimal emacs major mode for editing gnuplot scripts")
+ (description "@code{emacs-mkmcc-gnuplot-mode} is a minimal emacs major
+mode for editing gnuplot scripts. It provides syntax highlighting,
+indentation and a command to plot the file.")
+ (license license:gpl3+)))