summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-17 12:40:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:44:29 -0500
commit41ec0573b81733e15b70312d81cf7fdf77dd63fe (patch)
tree4e95786550ac717bbebc24c7b5f4e3c46ecd1825 /gnu
parent6f36d0c89e3bf19bb7bb8f7f5b77de30c9af861b (diff)
downloadguix-patches-41ec0573b81733e15b70312d81cf7fdf77dd63fe.tar
guix-patches-41ec0573b81733e15b70312d81cf7fdf77dd63fe.tar.gz
gnu: Remove meson-0.59 workarounds.
Mostly automated with the following command: $ grep --include='*.scm' '#:meson ,meson-0.59' -rl \ | xargs sed -z 's/#:meson[^\n]*\s*//' -i * gnu/packages/freedesktop.scm (malcontent) (accountsservice): Delete #:meson argument. * gnu/packages/games.scm (gnome-2048): Likewise. * gnu/packages/geo.scm (gnome-maps): Likewise. * gnu/packages/gnome.scm (gnome-photos, gnome-music) (gnome-initial-setup, gnome-user-share, gnome-characters) (gnome-disk-utility, gnome-font-viewer, evince, glade3) (gnome-mines, gnome-sudoku, gnome-settings-daemon, devhelp) (totem, eog, gvfs, simple-scan, epiphany, gnome-session, gedit) (network-manager-applet, gnome-control-center, gnome-shell, nautilus) (gnome-default-applications, gnome-weather, gnome-tweaks, cheese, gthumb) (gitg, polari, gnome-boxes, gtranslator): Likewise. * gnu/packages/gtk.scm: (gtkmm-3): Likewise. * gnu/packages/pdf.scm (zathura): Likewise. * gnu/packages/photo.scm (entangle): Likewise. * gnu/packages/video.scm (pitivi): Likewise. * gnu/packages/virtualization.scm (libvirt-glib): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm6
-rw-r--r--gnu/packages/games.scm1
-rw-r--r--gnu/packages/geo.scm3
-rw-r--r--gnu/packages/gnome.scm90
-rw-r--r--gnu/packages/gtk.scm6
-rw-r--r--gnu/packages/pdf.scm3
-rw-r--r--gnu/packages/photo.scm1
-rw-r--r--gnu/packages/video.scm3
-rw-r--r--gnu/packages/virtualization.scm2
9 files changed, 29 insertions, 86 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a7d400d3bf..844191a438 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -353,8 +353,7 @@ tests.")
(base32 "0vnf0pk516fwwh41v96c29l2i7h1pnwhivlkbf53kkx1q35g7lb3"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
;; AppInfo not available inside build environment.
@@ -1378,8 +1377,7 @@ message bus.")
(base32 "16wwd633jak9ajyr1f1h047rmd09fhf3kzjz6g5xjsz0lwcj8azz"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;see https://github.com/mesonbuild/meson/issues/6470
- #:tests? #f ; XXX: tests require DocBook 4.1.2
+ `(#:tests? #f ; XXX: tests require DocBook 4.1.2
#:configure-flags
'("--localstatedir=/var"
"-Dsystemdsystemunitdir=/tmp/empty"
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 725838ca1f..dab1d797e0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1757,7 +1757,6 @@ destroying an ancient book using a special wand.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8e5965c97c..0f965b120d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -229,8 +229,7 @@ topology functions.")
"037xmkmcmcw87vb1c1s3y225m8757k331cvk1m8cshf6mx61p0l1"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 429b17c00e..74ad58dd32 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -886,8 +886,7 @@ tomorrow, the rest of the week and for special occasions.")
"1bzi79plw6ji6qlckhxnwfnswy6jpnhzmmyanml2i2xg73hp6bg0"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
(list "-Ddogtail=false" ; Not available
;; Required for RUNPATH validation.
@@ -958,8 +957,7 @@ cloud integration is offered through GNOME Online Accounts.")
"0lcdal4qdhclr8961p57xf010y92l6wwmkw86lyi9wy224z6gjr0"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-gnome-music
@@ -1494,8 +1492,7 @@ extraction, and lookup for applications on the desktop.")
"06q3p4f8g9zr7a4mw3qr556mi0dg9qzrj8n46ybdz93fxs26aaj1"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:configure-flags '(;; Enable camera support for user selfie.
+ `(#:configure-flags '(;; Enable camera support for user selfie.
"-Dcheese=auto"
"-Dsystemd=false")
#:phases (modify-phases %standard-phases
@@ -1560,8 +1557,7 @@ tour of all gnome components and allows the user to set them up.")
"04r9ck9v4i0d31grbli1d4slw2d6dcsfkpaybkwbzi7wnj72l30x"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
`("-Dsystemduserunitdir=/tmp/empty"
;; Enable nautilus extension for file sharing.
@@ -2036,8 +2032,7 @@ to other formats.")
"0z2xa4w921bzpzj6gv88pvbrijcnnwni6jxynwz0ybaravyzaqha"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases (modify-phases %standard-phases
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)
@@ -2273,8 +2268,7 @@ and keep up to date translations of documentation.")
"1rr1ypb89p51b6428yqvczmpmylwjfnhnkgx78hzm3vxm3m15lff"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:configure-flags '("-Dlogind=libelogind")
+ `(#:configure-flags '("-Dlogind=libelogind")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -2323,8 +2317,7 @@ and keep up to date translations of documentation.")
"0hpyi0sz3gcqqs9lkwyk8b6hr39m3n27432x98kxr436jj37dk6j"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-post-install-script
(lambda _
@@ -2593,8 +2586,7 @@ forgotten when the session ends.")
"0xrwls1bhvny8vvd7mfjy9p26zjch0pd6x6j9jn9g2ka6xwyrxqg"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:build-type "release"
#:configure-flags
'("-Dnautilus=false"
@@ -3187,8 +3179,7 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
"glade-test-widget-null-icon.patch"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
@@ -5092,7 +5083,6 @@ and other secrets. It communicates with the \"Secret Service\" using DBus.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -5174,7 +5164,6 @@ once.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -5572,8 +5561,7 @@ services for numerous locations.")
(patches (search-patches "gnome-settings-daemon-gc.patch"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
(list (string-append "-Dudev_dir="
(assoc-ref %outputs "out") "/lib/udev")
@@ -5746,7 +5734,6 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -6277,8 +6264,7 @@ discovery protocols.")
grilo-plugins
vala))
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
;; Disable automatic GStreamer plugin installation via PackageKit and
;; all that.
@@ -6430,8 +6416,7 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
"0ddjwcd77nw0rxb5x5bz5hd671m8gya9827p8rsnb58x103kpai8"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:configure-flags
+ `(#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'eog' path component.
(list (string-append "-Dc_link_args=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib/eog"))
@@ -6562,8 +6547,7 @@ part of udev-extras, then udev, then systemd. It's now a project on its own.")
"1hlxl6368h6nyqp1888szxs9hnpcw98k3h23dgqi29xd38klzsmj"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
(list "-Dsystemduserunitdir=no"
"-Dtmpfilesdir=no"
@@ -6682,8 +6666,7 @@ USB transfers with your high-level application or system daemon.")
(build-system meson-build-system)
;; TODO: Fix icons in home screen, About dialogue, and scan menu.
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t))
+ `(#:glib-or-gtk? #t))
(native-inputs
(list gettext-minimal
itstool
@@ -6795,7 +6778,6 @@ a secret password store, an adblocker, and a modern UI.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -7185,8 +7167,7 @@ such as gzip tarballs.")
(base32
"02z0xr6sv9ibl7awbw9j4y05hf4jk1zgvsbbmh7n27hhjvsvc8pl"))))
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-gnome-session
@@ -7299,8 +7280,7 @@ javascript engine and the GObject introspection framework.")
"149ngl9qw6h59546lir1pa7hvw23ppsnqlj9mfqphmmn5jl99qsm"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
;; Otherwise, the RUNPATH will lack the final path component.
(list (string-append "-Dc_link_args=-Wl,-rpath="
@@ -8149,8 +8129,7 @@ Cisco's AnyConnect SSL VPN.")
"1gj6lqqi613j2m49v9i82lqg1rv7kwwc8z4nxjcwpaa0ins803f7"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
'("-Dappindicator=yes")))
(native-inputs
@@ -8504,7 +8483,6 @@ usage and information about running processes.")
(base32
"1a9ynlwwkb3wpg293ym517vmrkk63y809mmcv9a21k5yr199x53c"))))
(build-system meson-build-system)
- (arguments `(#:meson ,meson-0.59))
(native-inputs
`(("glib:bin" ,glib "bin") ; for gdbus-codegen, etc.
("gtk+" ,gtk+ "bin") ; gtk-update-icon-cache
@@ -8540,8 +8518,7 @@ devices using the GNOME desktop.")
"0rr4d5m2a72vrb31jgyx49dp0s2pwgyxsrk4hyw5ym66wq63c3v1"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags
(list "-Dcheese=false"
(string-append "-Dgnome_session_libexecdir="
@@ -8653,8 +8630,7 @@ properties, screen resolution, and other GNOME parameters.")
"0ragmcln210zvzhc2br33yprbkj9drjzd7inp5sdxra0a7l73yaj"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:disallowed-references ,(list (gexp-input glib "bin")
(gexp-input libxslt)
(gexp-input ruby-sass))
@@ -9095,7 +9071,6 @@ shared object databases, search tools and indexing.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-extensible
@@ -9296,8 +9271,6 @@ beautifying border effects.")
("vala" ,vala)))
(inputs
(list dconf gtk+ libxml2))
- (arguments
- `(#:meson ,meson-0.59))
(home-page "https://gitlab.gnome.org/GNOME/dconf-editor")
(synopsis "Graphical editor for GNOME's dconf configuration system")
(description
@@ -9394,8 +9367,7 @@ associations for GNOME.")
libgweather
libhandy))
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
,#~(modify-phases %standard-phases
(add-after 'unpack 'fix-service-file
@@ -9755,7 +9727,6 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
;; gnome-calendar has to be installed before the tests can be run
;; https://bugzilla.gnome.org/show_bug.cgi?id=788224
#:tests? #f
@@ -9895,7 +9866,6 @@ existing databases over the internet.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59
#:configure-flags '("-Dlocalstatedir=/tmp"
"-Dsysconfdir=/tmp")
#:imported-modules ((guix build python-build-system)
@@ -10683,8 +10653,7 @@ photo-booth-like software, such as Cheese.")
"0vyim2avlgq3a48rgdfz5g21kqk11mfb53b2l883340v88mp7ll8"))
(patches (search-patches "cheese-vala-update.patch"))))
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
;; Tests require GDK.
#:tests? #f
#:phases
@@ -11100,11 +11069,6 @@ functionality.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
-
- ;; See
- ;; <https://github.com/mesonbuild/meson/issues/9492#issuecomment-973117289>.
- #:meson ,meson-0.59
-
#:configure-flags
;; Ensure the RUNPATH contains all installed library locations.
(list (string-append "-Dc_link_args=-Wl,-rpath="
@@ -11340,8 +11304,7 @@ higher level porcelain stuff.")
"0npg4kqpwl992fgjd2cn3fh84aiwpdp9kd8z7rw2xaj2iazsm914"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-post-install-partially
@@ -11601,8 +11564,7 @@ environment.")
"001h9gppn79gnj7dl61jl9gas5wmbjdx0v8xwsx7v4xsv2hwz91g"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
@@ -11665,8 +11627,7 @@ integrate seamlessly with the GNOME desktop.")
(search-patches "gnome-boxes-add-guix-logo.patch"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59 ;positional arguments error with meson 0.60
- #:glib-or-gtk? #t
+ `(#:glib-or-gtk? #t
#:configure-flags (list "-Drdp=false"
(string-append "-Dc_link_args=-Wl,-rpath="
(assoc-ref %outputs "out")
@@ -12580,8 +12541,7 @@ your data.")
(propagated-inputs
(list gtksourceview)) ; required for source view
(arguments
- `(#:meson ,meson-0.59
- #:build-type "release"
+ `(#:build-type "release"
#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a5b804d848..781c66192c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1809,12 +1809,6 @@ tutorial.")
name "-" version ".tar.xz"))
(sha256
(base32 "1ri2msp3cmzi6r65ghwb8gfavfaxv0axpwi3q60nm7v8hvg36qw5"))))
- (arguments
- (substitute-keyword-arguments (package-arguments gtkmm)
- ;; Use meson 0.59 to workaround a new issue with meson 0.60 (see:
- ;; https://github.com/mesonbuild/meson/issues/9350#issuecomment-953799600).
- ((#:meson _ #f)
- meson-0.59)))
(propagated-inputs
`(("atkmm-2.28" ,atkmm-2.28)
("cairomm-1.14" ,cairomm-1.14)
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index de4ad2582a..d4e97e1d82 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -632,8 +632,7 @@ by using the poppler rendering engine.")
(files '("lib/zathura")))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.59
- #:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-before 'check 'start-xserver
;; Tests require a running X server.
(lambda* (#:key inputs #:allow-other-keys)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 913e1070f7..a05fd166b8 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -622,7 +622,6 @@ such as Batch image processing.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.59 ;fails to build with Meson 0.60
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d6b725de4e..70688abac6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4387,9 +4387,6 @@ tools for styling them, including a built-in real-time video preview.")
("pkg-config" ,pkg-config)))
(arguments
`(#:glib-or-gtk? #t
- ;; Pitivi is not yet compatible with Meson 0.60:
- ;; https://gitlab.gnome.org/GNOME/pitivi/-/issues/2593
- #:meson ,meson-0.59
#:phases
(modify-phases %standard-phases
(add-after 'glib-or-gtk-wrap 'wrap-other-dependencies
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 6a40955dbb..c4d4fefa66 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1347,8 +1347,6 @@ to integrate other virtualization mechanisms if needed.")
(base32
"1gdcvqz88qkp402zra9csc6391f2xki1270x683n6ixakl3gf8w4"))))
(build-system meson-build-system)
- (arguments
- `(#:meson ,meson-0.59)) ;KeyError: 'install_dir' with meson 0.60
(inputs
(list openssl cyrus-sasl lvm2 ; for libdevmapper
libyajl))