summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-25 21:58:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-25 21:59:07 +0200
commit41097b2dee9367974c6dd16ac1ba2ee945457237 (patch)
tree29f6ed278eb6eceea3a356566f263e5303bce713 /gnu
parent12ea2571221fc08b961c9fd38420648126ac6674 (diff)
downloadguix-patches-41097b2dee9367974c6dd16ac1ba2ee945457237.tar
guix-patches-41097b2dee9367974c6dd16ac1ba2ee945457237.tar.gz
gnu: libvirt: Don't use bogus cgroup.
Should fix <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36634>. * gnu/packages/virtualization.scm (libvirt)[source]: Add patch. * gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch34
-rw-r--r--gnu/packages/virtualization.scm16
3 files changed, 44 insertions, 7 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index eb3b0dcd3b..96b5dec029 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1042,6 +1042,7 @@ dist_patch_DATA = \
%D%/packages/patches/libutils-add-includes.patch \
%D%/packages/patches/libutils-remove-damaging-includes.patch \
%D%/packages/patches/libvdpau-va-gl-unbundle.patch \
+ %D%/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
%D%/packages/patches/libvpx-use-after-free-in-postproc.patch \
%D%/packages/patches/libxslt-generated-ids.patch \
diff --git a/gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch b/gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch
new file mode 100644
index 0000000000..5bfefa70bb
--- /dev/null
+++ b/gnu/packages/patches/libvirt-remove-ATTRIBUTE_UNUSED.patch
@@ -0,0 +1,34 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Thu, 25 Jul 2019 21:48:25 +0200
+Subject: [PATCH]: libvirt: remove ATTRIBUTE_UNUSED
+
+This should fix the error reported here[0]. Patch taken verbatim from
+upstream[1].
+
+[0]: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36634#28
+[1]: https://github.com/libvirt/libvirt/commit/759bf903a6c24a8efa25c7cf4b099d952eda9bd3
+
+From 759bf903a6c24a8efa25c7cf4b099d952eda9bd3 Mon Sep 17 00:00:00 2001
+From: Pavel Hrdina <phrdina@redhat.com>
+Date: Mon, 22 Jul 2019 14:46:34 +0200
+Subject: [PATCH] vircgroupv2: remove ATTRIBUTE_UNUSED for used attribute
+
+Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
+Acked-by: Peter Krempa <pkrempa@redhat.com>
+---
+ src/util/vircgroupv2.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/util/vircgroupv2.c b/src/util/vircgroupv2.c
+index af3192c99c..e36c36685b 100644
+--- a/src/util/vircgroupv2.c
++++ b/src/util/vircgroupv2.c
+@@ -399,7 +399,7 @@ virCgroupV2EnableController(virCgroupPtr group,
+
+
+ static int
+-virCgroupV2MakeGroup(virCgroupPtr parent ATTRIBUTE_UNUSED,
++virCgroupV2MakeGroup(virCgroupPtr parent,
+ virCgroupPtr group,
+ bool create,
+ unsigned int flags)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index c6371a6ac1..7c69f7b60e 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -391,13 +391,15 @@ manage system or application containers.")
(package
(name "libvirt")
(version "5.5.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://libvirt.org/sources/libvirt-"
- version ".tar.xz"))
- (sha256
- (base32
- "1s1mzw4cmkcfivs1kphpgy4lpddx0w1qnjysr4ggk5558w4yy1i3"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://libvirt.org/sources/libvirt-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "1s1mzw4cmkcfivs1kphpgy4lpddx0w1qnjysr4ggk5558w4yy1i3"))
+ (patches
+ (search-patches "libvirt-remove-ATTRIBUTE_UNUSED.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags