summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 07:50:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:40 +0200
commit40b0c09d2711dca951d272e51c21f4764e537211 (patch)
tree7475c86d1183f7a3f1a689a8fcc2cd05013b0318 /gnu
parent68a7e9c749012323725668573527b81742d75080 (diff)
downloadguix-patches-40b0c09d2711dca951d272e51c21f4764e537211.tar
guix-patches-40b0c09d2711dca951d272e51c21f4764e537211.tar.gz
gnu: texlive-generic-listofitems -> texlive-listofitems.
* gnu/packages/tex.scm (texlive-listofitems): New variable. (texlive-generic-listofitems): Deprecate variable. (texlive-latex-readarray): * gnu/packages/maths.scm (hypre): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/tex.scm46
2 files changed, 18 insertions, 30 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fe4d23c2e8..4c9d379eab 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5797,7 +5797,7 @@ set.")
texlive-wasy
texlive-xcolor
texlive-xypic
- texlive-generic-listofitems
+ texlive-listofitems
texlive-latex-cmap
texlive-latex-colortbl
texlive-latex-float
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b91df6527d..a371eb7151 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9590,40 +9590,28 @@ level of curly braces are removed from the values.")
(define-deprecated-package texlive-generic-kvsetkeys texlive-kvsetkeys)
-(define-public texlive-generic-listofitems
+(define-public texlive-listofitems
(package
- (name "texlive-generic-listofitems")
+ (name "texlive-listofitems")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/generic/listofitems"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1wnbnfrhi6hgqa78jsw6hljzi03i5x99mlr5n2419hgws52hk67y"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/generic/listofitems")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/listofitems")
+ (source (texlive-origin
+ name version
+ (list "doc/generic/listofitems"
+ "tex/generic/listofitems")
+ (base32
+ "1vzp4qkpfxzgcll1ak9syyc91sl93k9wr5rgfqvd6d6rgrnh3ava")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/listofitems")
(synopsis "Grab items in lists using user-specified separation character")
(description
- "This package allows one to capture all the items of a list, for which
-the parsing character has been selected by the user, and to access any of
-these items with a simple syntax.")
+ "This package is designed to read a list, for which the parsing character
+has been selected by the user, and to access any of these items with a simple
+interface.")
(license license:lppl1.3c+)))
+(define-deprecated-package texlive-generic-listofitems texlive-listofitems)
+
(define-public texlive-ltxcmds
(let ((template (simple-texlive-package
"texlive-ltxcmds"
@@ -9734,7 +9722,7 @@ values are not limited.")
(copy-recursively (assoc-ref %build-inputs "source") target)
#t))))
(propagated-inputs
- (list texlive-generic-listofitems))
+ (list texlive-listofitems))
(home-page "https://www.ctan.org/pkg/readarray")
(synopsis "Read, store and recall array-formatted data")
(description