summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-27 16:00:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-27 16:53:01 +0300
commit40a7da2b14b4704bc1c8c2f5fdeb2451b232113c (patch)
tree1b117e05f5ecd6bb2391541ad1eedb35f4aa19d6 /gnu
parentced47448b0c6619e8d7cd83823f0fd327dca9f10 (diff)
downloadguix-patches-40a7da2b14b4704bc1c8c2f5fdeb2451b232113c.tar
guix-patches-40a7da2b14b4704bc1c8c2f5fdeb2451b232113c.tar.gz
gnu: Add julia-tableiointerface.
* gnu/packages/julia-xyz.scm (julia-tableiointerface): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 52b94a2932..a81aa7f0b7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1756,6 +1756,27 @@ linear algebra operations.")
warnings (stderr) or both streams at the same time.")
(license license:expat)))
+(define-public julia-tableiointerface
+ (package
+ (name "julia-tableiointerface")
+ (version "0.1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lungben/TableIOInterface.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p2fi9jbyfg2j6rysv4if7dx8qw2mssb04i75j1zq607j8707kvn"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/lungben/TableIOInterface.jl")
+ (synopsis "File formats based on file extensions")
+ (description "This package determines tabular file formats based on file
+extensions. It is intended to be the base both for @code{TableIO.jl} and for
+the @code{Pluto.jl} tabular data import functionality.")
+ (license license:expat)))
+
(define-public julia-unpack
(package
(name "julia-unpack")