summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 16:53:20 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 17:14:08 +0200
commit409fcee9e5074987ee251c9c025c437fbf0671c7 (patch)
tree536258517c293dea7462ab224cdacd95e2bbc2ae /gnu
parent106354eaa42ceb83cf1eff66aee220531452a5c4 (diff)
downloadguix-patches-409fcee9e5074987ee251c9c025c437fbf0671c7.tar
guix-patches-409fcee9e5074987ee251c9c025c437fbf0671c7.tar.gz
gnu: Add clump.
* gnu/packages/lisp-xyz.scm (cl-clump, sbcl-clump): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cf5e763c78..2840539816 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12019,3 +12019,18 @@ sequences of objects.")
'(#:asd-file "Binary-tree/clump-binary-tree.asd"
#:asd-system-name "clump-binary-tree"))
(synopsis "Implementation of binary trees for Common Lisp")))
+
+(define-public sbcl-clump
+ (package
+ (inherit sbcl-clump-2-3-tree)
+ (name "sbcl-clump")
+ (arguments
+ '(#:asd-file "clump.asd"
+ #:asd-system-name "clump"))
+ (inputs
+ `(("clump-2-3-tree" ,sbcl-clump-2-3-tree)
+ ("clump-binary-tree" ,sbcl-clump-binary-tree)))
+ (synopsis "Collection of tree implementations for Common Lisp")))
+
+(define-public cl-clump
+ (sbcl-package->cl-source-package sbcl-clump))