summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAlice BRENON <alice.brenon@ens-lyon.fr>2022-08-11 14:29:44 +0200
committerDavid Thompson <dthompson2@worcester.edu>2022-08-31 14:48:16 -0400
commit3f3abddeeebd75987686e3735a4f3454494a95b9 (patch)
tree7ef633dade0d87a8edcc2c32571da7f8ca38cf6d /gnu
parent13887e1f21ec7d3f88417ded443681f5a91b728d (diff)
downloadguix-patches-3f3abddeeebd75987686e3735a4f3454494a95b9.tar
guix-patches-3f3abddeeebd75987686e3735a4f3454494a95b9.tar.gz
gnu: Add ghc-roman-numerals.
* gnu/packages/haskell-xyz.scm (ghc-roman-numerals): New variable. Signed-off-by: David Thompson <davet@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 039f4871f2..a01248f355 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
-;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
+;;; Copyright © 2021, 2022 Alice BRENON <alice.brenon@ens-lyon.fr>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -10913,6 +10913,27 @@ expose it from another module in the hierarchy.
@end itemize")
(license license:expat)))
+(define-public ghc-roman-numerals
+ (package
+ (name "ghc-roman-numerals")
+ (version "0.5.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "roman-numerals" version))
+ (sha256
+ (base32
+ "10da5vls9l5i255bapms4b2r7dnwmxgsaa1cdll2lrmid5dikixr"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-base-unicode-symbols))
+ (home-page "https://github.com/roelvandijk/roman-numerals")
+ (synopsis "Parsing and pretty printing of Roman numerals")
+ (description
+ "This library provides functions for parsing and pretty printing Roman numerals.
+Because the notation of Roman numerals has varied through the centuries this
+package allows for some customisation using a configuration that is passed to
+the conversion functions.")
+ (license license:bsd-3)))
+
(define-public ghc-safe
(package
(name "ghc-safe")